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1. ПАСПОРТ КОМПЛЕКТА КОНТРОЛЬНО-ОЦЕНОЧНЫХ СРЕДСТВ 

1.1. Область применения контрольно-оценочных средств (далее – КОС) 

Контрольно-оценочные средства предназначены для оценки освоения основного вида 

деятельности и уровня сформированности соответствующих ему общих и профессиональных 

компетенций в процессе текущего и рубежного контроля, промежуточной аттестации. 

1.1.1. Перечень общих компетенций 

Код Наименование общих компетенций 

ОК 01. Выбирать способы решения задач профессиональной деятельности 

применительно к различным контекстам; 

ОК 02. Использовать современные средства поиска, анализа и интерпретации 

информации, и информационные технологии для выполнения задач 

профессиональной деятельности; 

ОК 03. Планировать и реализовывать собственное профессиональное и личностное 

развитие, предпринимательскую деятельность в профессиональной сфере, 

использовать знания по финансовой грамотности в различных жизненных 

ситуациях; 

ОК 04. Эффективно взаимодействовать и работать в коллективе и команде 

ОК 05. Осуществлять устную и письменную коммуникацию на государственном языке 

Российской Федерации с учетом особенностей социального и культурного 

контекста; 

ОК 06. Проявлять гражданско-патриотическую позицию, демонстрировать осознанное 

поведение на основе традиционных общечеловеческих ценностей, в том числе с 

учетом гармонизации межнациональных и межрелигиозных отношений, 

применять стандарты антикоррупционного поведения; 

ОК 07. Содействовать сохранению окружающей среды, ресурсосбережению, применять 

знания об изменении климата, принципы бережливого производства, 

эффективно действовать в чрезвычайных ситуациях; 

ОК 08. Использовать средства физической культуры для сохранения и укрепления 

здоровья в процессе профессиональной деятельности и поддержания 

необходимого уровня физической подготовленности; 

ОК 09. Пользоваться профессиональной документацией на государственном и 

иностранном языках. 
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1.1.2. Перечень профессиональных компетенций  

Код Наименование видов деятельности и профессиональных компетенций 

ВД 3 Разработка веб приложения на стороне клиента 

ПК 3.1. Проектировать структуры разделов информационных ресурсов с целью 

создания эскиза и прототипа интерфейса пользователя. 

ПК 3.2. Разрабатывать интерфейс пользователя для информационных ресурсов с 

использованием стандартов в области веб-разработки. 

ПК 3.3. Создавать структуру кода веб-страницы информационных ресурсов в 

соответствии с дизайн-макетом. 

ПК 3.4. Создавать программный код на стороне клиента в соответствии с техническим 

заданием (спецификацией) с использованием языков программирования, 

библиотек и фреймворков. 

 

1.1.3. В результате освоения профессионального модуля обучающийся должен
1
: 

Владеть навыками − разработки эскизов, схем, прототипов интерфейса пользователя 

информационного ресурса; 

− разработки дизайна компонентов интерфейса пользователя в 

соответствии со стандартами и требованиями заказчика; 

− разработки программного кода веб-страниц информационного 

ресурса, в том числе с использованием готовых технических 

решений; 

− разработки кроссбраузерной верстки веб-страниц 

информационного ресурса; 

− разработки клиентской части web-приложения в соответствии с 

техническим заданием (спецификацией). 

Уметь − применять программные средства для разработки интерфейса; 

− применять инструменты для оценки эффективности и удобства 

созданного интерфейса; 

− применять полученные данные для оптимизации интерфейса; 

− применять нормативные документы, определяющие требования к 

оформлению интерфейсов информационных ресурсов; 

− создавать адаптивный интерфейс web-ресурса; 

− применять специализированное программное обеспечение для 

                                                      
1
 Берутся сведения, указанные по данному виду деятельности в п. 4.2. 
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верстки страниц информационных ресурсов; 

− использовать язык разметки страниц информационных ресурсов; 

− применять выбранные языки программирования для написания 

программного кода; 

− использовать выбранную среду программирования и средства 

системы управления базами данных; 

− использовать возможности имеющейся программной 

архитектуры информационного ресурса. 

Знать − современные принципы построения интерфейсов пользователя; 

− основные требования, предъявляемые к дизайну графических 

интерфейсов; 

− способы представления информации с учетом особенностей 

пользователя: возрастных, особенностей ограниченных 

возможностей здоровья и др.; 

− особенности отображения элементов интерфейсов web-ресурсов в 

различных браузерах; 

− правила реализации адаптивного интерфейса web-ресурса; 

− методы повышения читаемости программного кода; 

− синтаксис выбранного языка программирования, особенностей 

программирования на этом языке, стандартных библиотек языка 

программирования; 

− отраслевую нормативную техническую документацию; 

− особенности выбранной среды программирования; 

− компоненты программно-технических архитектур 

информационных ресурсов, существующих приложений и 

интерфейсов взаимодействия с ними; 

− сетевые протоколы и основы web-технологий; 

− современные стандарты взаимодействия компонентов 

распределенных приложений; 

− программные средства и платформы для разработки web-

ресурсов; 

− основы информационной безопасности web-ресурсов. 

2.  

3.  
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4. ФОРМЫ КОНТРОЛЯ И ОЦЕНКИ ОСВОЕНИЯ УЧЕБНОЙ ДИСЦИПЛИНЫ ПО 

ТЕМАМ (РАЗДЕЛАМ) 

Предметом оценки служат умения и знания, предусмотренные ФГОС по дисциплине 

(название дисциплины), направленные на формирование общих и профессиональных 

компетенций. 

(технология оценки З и У по дисциплине прописывается в соответствии со спецификой 

дисциплины. Если экзамен проводится поэтапно или предусмотрена рейтинговая система 

оценки, то это подробно описывается) 

Контроль и оценка освоения учебной дисциплины по темам (разделам) 

 

 

 
Элемент 
учебной 

дичциплины 

Формы и методы контроля 

Текущий контроль Рубежный контроль 
(контроль по разделу) 

Промежуточная 
аттестация 

Форма 
контроля Проверяемы

е ОК; У, З 

Форма 

контрол

я 

Проверяе 

мые 
ОК; У, З 

Форма 

контрол

я 

Проверяем

ые ОК; 

У, З 

Раздел 1 (наименование) 

Тема 1.1 
(название) 

Устный опрос 
№1 (или 
Практическая 
работа 1,…) 

У1, З2, 

ОК3, 

ОК6.,ПК1

.1, ПК1.2 

 

_ _ _ _ 

Тема 1.2 Устный опрос 

№2 (или Тест 

№1, 

Лабораторная 

работа 1…) 

У2, У3, З1, 
З3, 
ОК2, ОК3., 

ПК1.1, 

ПК1.2 

 

_ 

 

_ 
 

_ 
 

_ 
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Тема 1.n Устный опрос 

№3 (или 

Самостоятельна

я работа 1, 

Практическая 
работа 2….) 

У.., З.., ОК…  

 

_ 

 

_ 
 

_ 
 

_ 

Контроль 
по 
разделу 1 

 

_ 

 

_ 

Контро 

льная 

работа 

№1 

У1.., У2…. 
З.1.. 

З2… 

ОК…, ОК…, 

ОК… 

ПК1.1, ПК1.2 

 

_ 

 

_ 

Раздел 2 (наименование) 

Тема 2.1 Устный опрос 
(или 
Самостоятельна
я работа 2 
Практическая 
работа 3…) 

У1, У2, 
3 1, 32, 33, 

ОК 

3, ОК 7 

ПК1.1-

ПК1.3 

 

_ 

 

_ 
 

_ 
 

_ 

Тема 2.2 Самостоятельна
я работа 2 
(или…) 

У.., З.., З.., 

ОК.., ОК…, 

ОК.. 

ПК1.1-ПК1.3 

_ _ _ _ 

Тема 2.n Форма контроля У.., З.., З.., 

ОК.., ОК…, 

ПК... 

_ _ _ _ 

Контроль 
по 
разделу 2 

_ _ 
Контроль
на 
я работа 

№ 2 

ОК…, ОК…, 

ОК… У.., 

У2…. 
З... З…ПК 

_ _ 

Раздел N(наименование) 

Тема N.1 
Форма контроля 

У.., З.., 
ОК.,.ПК 

_ _ _ _ 

Тема N.2 Форма контроля У.., З.., 

ОК..,ПК 

_ _ _ _ 

Контроль 
по 
разделу N 

 

_ 

 

_ 

Форма 

контр

оля 

З,У, ОК, ПК  

_ 

 

_ 

Промежуточ
на я 
аттестация 

 

_ 

 

_ 
 

_ 
 

_ 

Форма 

контр

оля 

У, З, ОК, 
ПК 
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5. КОНТРОЛЬНО-ОЦЕНОЧНЫЕ СРЕДСТВА ДЛЯ ПРОВЕДЕНИЯ 

ТЕКУЩЕГО КОНТРОЛЯ (КОНТРОЛЬ УСВОЕНИЯ ЗНАНИЙ И 

ОСВОЕНИЯ УМЕНИЙ) 

 

ПРАКТИЧЕСКИЕ ЗАДАНИЯ 

 

Раздел 1 Проектирование и дизайн интерфейсов 

 
Лабораторная работа №1 Adobe Photoshop 

Тема: Текстовые эффекты 

Задание 1. Изгиб и текстура 

1.     Создаем новую заготовку (например, 300*240, разрешением 150, RGB с белым фоном). 

2.     Пишем COMPUTER DESIGN горизонтальным текстом , искажаем как флаг (Текст 

– Деформировать текст…), настраиваем параметры. 

 

3.     Пишем LIKE I вертикальным текстом , искажаем как 

дугу (Текст – Деформировать текст…), настраиваем параметры. 

 
4.     Объединяем оба текстовых слоя (но не задний план!) (Выделите слои, 

используя Ctrl+щелчок по слою левой клавишей мыши, затем нажмите комбинацию 

клавиш Ctrl+E). 

5.     Открываем fern.jpg. Переносим картинку в нашу заготовку (Ctrl+A (выделить 

всѐ), Ctrl+C (скопировать), Ctrl+V (вставить)). При необходимости растягиваем 

картинку, чтобы она закрывала все надписи. 

6.     Слой / Создать обтравочную маску. 

 
Задание 2. Кровь 
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1.     Создаем новую заготовку 400*400, разрешением 150, RGB, с черным 

фоном (Alt+Backspace). 

2.     Используя белый цвет, пишем «blood» шрифтом Times New Roman, Italic 25 пунктов 

по центру. 

3.     Растрируем текстовый слой (Текст – Растрировать текстовый слой). 

4.     Сводим слои (Ctrl+E). 

5.     Изображение / Вращение изображения / 90 против часовой 

6.     Фильтр / Стилизация / Ветер, Способ - Ветер, Направление - Слева. Повторить этот 

фильтр еще 3 раза (Ctrl+F). 

 
7.     Разворачиваем холст обратно (Изображение / Вращение изображения / 90 по часовой). 

8.     Фильтр / Галерея фильтров … / Эскиз / Линогравюра. Тоновой баланс: 5-6, Смягчение: 

1-3. 

9.     Изображение / Коррекция / Инверсия. 

10. Выделить текст. 

11. Выбрать основной цвет для заливки текста. Залить текст. 

12. Фильтр / Галерея фильтров / Bas Relief. Detail: 12, Smoothness: 5. 

 
Задание 3. Лед 

1.     Создаем новую заготовку 300*200, разрешением 150, черно-белую с белым фоном. 

2.     Используя черный цвет, пишем ―ice‖ шрифтом Times New Roman, Bold Italic 25 

пунктов по центру. 

3.     Растрируем текстовый слой. 

4.     Фильтр / Шум / Добавить шум, 70%, одноцветный. 

5.     Сводим слои. 

6.     Фильтр / Pixelate / Crystallize, Cell Size = 3 

7.     Изображение / Повернуть холст / 90 против часовой 

8.     Проинвертировать цвета: Изображение / Регулировки / Инвертировать 

9.     Для создания сосулек: Фильтр / Stylize / Wind, Method - Wind, Direction - From the left. 

10. Разворачиваем холст обратно 

11. Изображение / Режим / RGB. 

12. Изображение / Регулировки / Тон/Насыщенность. Включить тонирование (190, 70, +3). 
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Задание 4. Пламя 

1.     Создаем новую заготовку (например, 300*100, разрешением 150, Черно-белое с белым 

фоном). 

2.     Пишем DESIGNER горизонтальным текстом. 

3.     Фильтр / Смазывание / Смазывание Гаусса 1 пкс. 

4.     Изображение / Повернуть холст / 90 против часовой. 

5.     Свести слои. 

6.     Проинвертировать цвета: Изображение / Регулировки / Инвертировать. 

7.     Для создания языков пламени: Фильтр / Stylize / Wind, Method - Wind, Direction - From 

the left. 

8.     Для большей реалистичности используем Фильтр / Distort / Ripple amount 50, size 

medium). 

9.     Разворачиваем холст обратно. 

10. Изображение / Режим / Индексированные цвета. 

11. Изображение / Режим / Палитра Black Body 

 
Задание 5. Лава 

1.     Создайте новый документ 600x600 с черным фоном (Alt+Backspace). Напишите 

крупный белый текст, продублируйте текстовый слой (Слои – Создать дубликат слоя 

…). Видимость копии отключите, объедините текстовый слой с фоном (Слои – 

Объединить слои, Ctrl+E). 

 
2.     Filter > Stylize > Wind (Method: Wind, Direction: From the 

left). Повторите несколько раз (CTRL+F). 

Filter > Stylize > Wind (Method: Wind, Direction: From the right). Повторите несколько раз 

(CTRL+F). 
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3.     Установите цвета по умолчанию (D). Затем Filter->Render->Difference 

Clouds. Включите видимость верхнего слоя и установите его прозрачность на 60%. 

Сведите слои. 

 
4.     Filter > Stylize > Extrude 

 
5.     Image > Adjustment > Invert 

 
6.     Filter > Sharpen > Unsharp Mask (Amount 500%, Radius: 2, Threshold: 0). Затем Filter > 
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Sharpen > Sharpen. Повторить пару раз. 

 
7.     Image > Adjustments > Color Balance: 

- Midtones: [ +100 ] [ 0 ] [ -40 ] 

- Shadows: [ +70 ] [ 0 ] [ -70 ] 

- Highligts: [ +80 ] [ 0 ] [ -40 ] 

 
Задание 8. Трехмерный текст 

1.     Создаем новую заготовку (например, 400*300, разрешением 150, черно-белое). 

2.     Заливаем фон черным цветом. 

3.     Используя белый цвет, пишем «3D-Text» шрифтом Garamond, Bold, 15 пунктов. 

4.     Редактирование / Трансформация / Искривление. Тянем вниз левый нижний угол. 

5.     Создаем копию слоя. 

6.     Отключаем слой-копию, объединяем текстовый слой с фоном. 

7.     Фильтр / Смазывание / Смазывание движением. Искажение: –20, Дистанция: 20. 

8.     Фильтр / Стилизация / Вычисление краев. 

9.     Изображение / Регулировки / Инвертировать 

10. Включаем копию слоя, задаем непрозрачность 70% и совмещаем слой с текстом с 

лицевой стороной трѐхмерной надписи. 

11. Создаем еще одну копию слоя, задаем непрозрачность 30% и совмещаем слой с текстом 

с задней стороной трѐхмерной надписи. 

 
Задание 9. Обведенные буквы 

1.     Создаем новую заготовку (например, 300*100, разрешением 150, RGB с белым фоном). 

2.     Пишем DESIGNER горизонтальным текстом. 
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3.     Фильтр / Стилизация / Вычисление краев. 

4.     Создать копию слоя. 

5.     Размыть копию: Фильтр / Смазывание / Смазывание Гаусса 2 пкс. 

6.     Копию сдвинуть. 

 
Задание 10. Текст, заполненный линиями 

1.     Создайте новый документ 300x300. Жесткой кистью 3 рх закрасьте линиями 

 
2.     Filter > Artistic > Cutout: Number of Levels - 7, Edge simplicity - 2, Edge Fidelity - 2 

3.     Сохраните изображение как .psd файл, он будет использован как карта смещения для 

другого файла 

4.     Создайте новый документ, напишите в нем крупный жирный текст 

5.     Filter > Distort > Displace, растрируйте текстовый слой 

 
6.     В качестве карты смещения выберите сохраненный .psd файл 

 
Задание 11. Стеклянный текст 

1.     Создайте документ произвольных размеров с белым фоном и черным напишите что-

нибудь на свое усмотрение 

 
2.     Примените к текстовому слою стиль слоя Drop Shadow со следующими настройками: 
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3.     Примените к текстовому слою стиль слоя Bevel and Emboss со следующими 

настройками: 

 
Здесь кликните по изображению контура (Gloss Contour) и вручную сделайте график 

примерно таким: 

 
4.     Примените к текстовому слою стиль слоя Color Overlay со следующими настройками: 

 
Вот, что должно получиться: 

 
Задание 7. Листок в линейку 

1.     Создайте новый документ размерами 400 на 400 пикселей. После этого создайте новый 

слой и выделите на нем прямоугольную область, залейте ее белым цветом. Затем, не 

снимая выделения, кликните в нем правой кнопкой мыши и выберите пункт Stroke. 
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Задайте настройки: Width: 1px, location: outside, opacity: 50%, color: #adc7e8 

2.     Примените к этому слою стиль Drop Shadow: 

 

 
3.     На новом слое инструментом Line Tool цветом #5a5858 делаем горизонтальные линии 

через равные расстояния. Для удобства отобразите сетку (Ctrl+'), настройте ее (Edit > 

Preferences > Guides, Grid & Slices) и включите привязку к сетку (View > Snap To > Grid) 

 
4.     Аналогично нарисуйте две вертикальные красные линии 

 
5.     Инструментом Lasso нарисуйте очертания фигуры, одна сторона которой и будет 

линией отрыва, и нажмите клавишу DELETE 
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6.     Если хотите, можете залить слой Background любым цветом 

 
7.     Для большей реалистичности можно применить к слою с линиями фильтр Sketch > 

Water Paper 

 
Задание 8. Папирус 

1.     Создадим новое изображение размером 200х200 пикселей с белым фоном. На новом 

слое с помощью инструмента Прямоугольное выделение (Rectangular marquee tool) 

нарисуем выделение произвольной формы и зальем его черным 

 
2.     Установим цвета по умолчанию (D). Снимем выделение и перейдем к команде Фильтр > 

Штрихи > Брызги (Filter > Brush Strokes > Spatter). Введем следующие значения: Радиус 

распыления (Spray radius): 10, Сглаживание (Smoothness): 5 
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3.     Повторим тот же фильтр с параметрами 20, 15. Теперь избавимся от «отвалившихся» 

кусочков черного. Активизируем инструмент Волшебная палочка (Magic wand tool), в 

опциях установим Отклонение (Tolerance) равным 5 и отметим Смежность (Contiguos). 

Теперь щелкнем в любом месте участка черного цвета и инвертируем выделение: 

Выделение > Инверсия (Select > Inverse) или Ctrl+Shift+I. Нажмем Del и инвертируем 

выделение обратно для перехода к черному 

 
4.     Зальем выделение на активном слое светло-желтым или бежевым цветом 

 
5.     Выберем в качестве основного коричневый цвет. Возьмем мягкую кисть диаметром в 

100 пикселей с непрозрачностью (Opacity) в размере 10%, активизируем на панели 

параметров Аэрограф. Проведем кистью вдоль границ нашего папируса; легкий мазок в 

центре тоже не повредит. Снимите выделение 

 
6.     Для большей реалистичности обработайте ластиком края. Примените Layer Style > Drop 

Shadow... 
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Задание 3. Рамки. Фигурная деревянная рамка 

 
1.     Создать свою заготовку. 

2.     Сделать контур рамки: выделить прямоугольником; преобразовать выделение в 

контур; изменять его, добавляя и двигая точки. 

3.     Скопировать выделение на новый слой. Загрузить выделение. 

4.     Открыть палитру стилей. Загрузить набор Textures. Запустить Oak. 

5.     Слой / Эффекты слоя / Рельефность. 

6.     Вставить фото (face), для него тоже применить Рельефность. 

Задание 4. Рамка из листьев 

1.     Создаем новое изображение с белым фоном. На новом слое создаем контур листика и 

заполяем его произвольным цветом, например, щелкнув правой кнопкой мыши по 

контуру и выбрав пункт Fill Path 

 
2.     Для того чтобы процесс наложения можно было контролировать и динамически 

изменять, применим соответствующий стиль к слою с лепестком. Перед этим определимся 

с цветами. К примеру, в панели инструментов установите цвет переднего плана как 

#77cc00, а фоновый цвет #3fa000. Теперь Layer > Layer style > Gradient Overlay и 

установите параметры, как на скриншоте. Градиент выбран от основного к фоновому 

 
3.     Щелкните правой кнопкой мыши в районе контура и выберите пункт Make Selection для 

того, чтобы избавиться от контура и выделить созданную им область. Теперь выполните 
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команду Edit > Define Brush Preset и введите имя создаваемой нами кисти 

4.     Создаем новый слой. Выбираем из панели инструментов Brush, в панели параметров 

созданную нами кисть и жмем F5 для открытия вкладки Brushes. Изменим параметры 

кисти. Для начала поставим флажок возле строки Shape Dynamics и изменим здесь Size 

Jitter, установив значение 100% и Angle Jitter, установив 70%. Далее ставим флажок 

Scattering, устанавливаем Scatter 261%, Count 1, Count Jitter 86 

5.     Теперь можно применять созданную и настроенную кисть для рисования рамки 

произвольными цветами. Для рамки, показанной ниже, использовался цвет переднего 

плана #a83e0a и фоновый цвет #c99565 

 

Задание 5. Двойная рамка 

1.     Создаем новое изображение 600 x 600 с прозрачным фоном. Устанавливаем цвет 

переднего плана #725418, заднего плана - белый 

2.     На новом слое выделяем прямоугольник и заливаем цветом переднего плана. Выделение 

снимаем 

 
3.     Filter > Sketch > Torn Edges (50, 1, 17) 

4.     Для удаления белой бахромы по краям рамки щелкаем волшебной палочкой с допуском 

100 внутри коричневого прямоугольника, инвертируем выделение и нажимаем Delete. 

Выделение снимаем 
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5.     Выделяем содержимое слоя. Select > Modify > Contract примерно на 8 - 10 px. Нажимаем 

Delete. Выделение снимаем 

 
6.     Применяем стиль слоя 

 
7.     Дублируем слой и применяем свободную трансформацию (Сtrl+T), уменьшая рамку на 

втором слое. Подгоняем еѐ размер, чтобы она как бы вошла внутрь первой 
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8.     Создаем 4 коричневых круга на углах рамки. В конечном итоге все кружки должны 

оказаться в одном слое 

 
9.     Применяем к слою с кругами настройки стиля BEVEL AND EMBOSS такие же, как мы 

применяли к самой рамке 

 
10. Объединяем слои с кружками и рамками и применяем стили слоя 
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11. Берем подходящую фотографию и вставляем ее в рамку. Нижним слоем используем 

какую-нибудь текстуру 

 
Лабораторная работа №5 

Тема: Имитация объема 

Задание 1. Имитация объема. Сфера 

 
1.     Заготовка. 

2.     Цветной текст 6.0, отрастрировать. 

3.     Фильтр Render / 3D Transform, сфера вокруг надписи, исказить. 

4.     Создать новый слой, перенести его под слой с надписью. Создать эллиптическое 

выделение, совпадающее с областью, образованной фильтром. 

5.     Ластиком стереть лишние серые участки сферы на слое с надписью. 

6.     Залить градиентом сферу. 
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7.     Для надписи – эффекты слоя Падающая тень, Внутренняя тень, Рельефность. 

8.     При необходимости трансформировать надпись. 

Задание 2. Имитация объема. Болт 

 
1.     Заготовка. 

2.     Создать круглое выделение, залить градиентом. 

3.     С помощью контуров создать полукруглые выделения для левой и правой части болта, 

скопировать их на отдельные слои. 

4.     К новым слоям применить эффекты Внутренняя тень, Атлас. 

5.     Свести слои. 

6.     Яркость / Контраст. 

7.     Фильтр Пикселизация / Мозаика. 

Задание 3. Имитация объема. Пуговица 

 
1.         Заготовка. 

2.         Создать круглое выделение для всей пуговицы, залить градиентом от центра: белый – 

черный – белый – черный. 

3.         Залить градиентом центр пуговицы: белый – черный от левого верхнего угла. 

4.         Фильтр Texture / Texturizer. 

5.         Применить к слою эффект Рельефности с текстурой. 

6.         Выделить две дырочки, залить белым, скопировать на новый слой. 

7.         Применить к слою эффекты Внутренние тени, Внешний отблеск. 

8.         Свести слои, раскрасить. 

Задание 4. Сферическая 3D-клетка 

1.         Создайте новый документ со следующими настройками: 

 
2.         Максимально увеличьте масштаб. Черным квадратным карандашом размером 5 

закрасьте левую часть 

 
Edit > Define Pattern. Назовите созданный узор «Горизонталь» 

3.         Image > Rotate Canvas > 90CW. 
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Edit > Define Pattern. Назовите созданный узор «Вертикаль». 

Теперь можно закрыть документ, не сохраняя 

4.         Создайте новый документ 500x500 с белым фоном. На новом слое сделайте круглую 

выделенную область 

 
5.         Edit > Fill. В разделе «Use» выбираем «Pattern», в разделе «Custom 

Pattern» выбираем «Горизонталь». Теперь выделение заполнено вертикальными линиями 

 
Аналогично заполните выделенную область горизонтальными линиями 

 
6.         Создайте дубликат слоя. К верхнему слою примените Filter > Distort > Spherize с 

параметрами Amount: 100%, Mode: Normal, к нижнему - с параметрами Amount: -100%, 

Mode: Normal. Снимите выделение 
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7.         Примените к обоим слоям стили слоя: 

 
Уменьшите Opacity второго слоя до 30% 

 
8.         Теперь можно разместить кого-нибудь между этими двумя слоями, подобрать фон и 

т.д. 

 

Задание 5. Кубическое яблоко 

1.     Откройте изображение 
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2.     Удалите серый фон и увеличьте размер холста до 800 х 800 рх 

 
3.     На новом слое белой кистью 25 рх нарисуйте каркас 

 
4.     Перейдите на слой с яблоком. Edit > Transform > Warp. Растягивайте сетку так, чтобы 

яблоко вписалось в каркас 

 
5.     Уменьшите прозрачность слоя с каркасом до 40%, размойте его примерно на 25 рх: 

Filter > Blur > Box Blur 
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Задание 6. Глобус 

1.     Создайте новый документ 60 x 60 рх с прозрачным фоном. 

Максимально увеличьте масштаб. Белым квадратным карандашом размером 4 px 

закрасьте вертикальную линию слева и горизонтальную линию внизу. 

Сохраните созданный узор: Edit > Define Pattern 

 
2.     Создайте новый документ 500x500 с белым фоном. На новом слое выделите окружность 

и залейте ее градиентом 

 
3.     Не снимая выделения, создайте новый слой «Grid» и залейте его созданным узором: Edit 

> Fill. Use: Pattern... 

 
4.     Создайте карту на новом верхнем слое 

 
и наложите ее на будущий глобус 
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5.     При выделенном слое с окружностью, перейдите на слой с картой и добавьте слой-

маску 

  

6.     При выделенном слое с окружностью, примените Filter > Distort > Spherize - Amount: 

100%, mode: Normal последовательно для всех трех слоев 

 
7.     Для слоя «Grid» примените режим наложения слоев «Overlay», а для слоя с картой –

 «Color Dodge» 

 

Задание 7. Планета 

1.     Создайте новый документ 500x500 с черным фоном. На новом слое выделите 

окружность 
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2.     Установите цвет переднего плана #BEB074, заднего плана #736942. На новом слое 

выполните Filter > Render > Clouds 

 
3.     Filter > Sharpen > Unsharp Mask 

 
4.     Продублируйте текущий слой (CTRL+J). Edit > Transform > Rotate 90CW. Установите 

режим слоя ―Overlay». 

Еще раз продублируйте слой и выполните те же действия 

 
5.     Сведите три верхних слоя с планетой. Добавьте эффект освещения Filter > Render > 



31  

Lighting Effects и настройте его 

 
6.     Filter > Distort > Spherize, amount 100%. Потом тот же фильтр, но аmount 50% 

 
7.     Теперь нарисуем звездное небо. Создайте новый слой и залейте его черным. Затем Filter 

> Noise > Add Noise. Потом скопируйте этот слой и установите режим слоя «Overlay» 

 
8.     Поэкспериментируйте со световыми эффектами, цветами и стилями слоя для планеты 

 

Задание 8. Трехмерная книга 

1.     Откройте изображение, используемое для обложки 
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2.     Добавьте фоновый слой, по размеру больший оригинала, чтобы в дальнейшем было 

удобно работать при создании трехмерного объекта. 

Добавьте нужный текст и картинки 

 
3.     Свяжите все слои и трансформируйте в режиме наклона 

 
4.     На новом слое создайте выделение для внешней части обложки и залейте черным. 

Также на новом слое создайте прямоугольное выделение вдоль обложки, 

трансформируйте его и залейте. Можно создать надпись небольшого размера. 

Заполните фоновый слой подходящим градиентом 
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5.     Перейдем к созданию страниц для книги. Создайте выделение на новом слое и 

заполните его белым 

 
6.     Чтобы будущие страницы не сливались в единую белую массу, к слою с белой заливкой 

примените стиль Drop Shadow (Тень) 

 
Добавьте страницы, копируя слой. Необязательно размещать эти страницы максимально 

ровно, должны быть небольшие искажения 

 
7.     Объедините слои со страницами, сотрите ненужные части, подкорректируйте 
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Задание 9. Трехмерная коробка 

1.     Откройте изображение, используемое для коробки 

 
2.     Прямоугольником выделите левую часть изображения, вырежьте на новый слой и 

сместите немного влево. 

Проделайте аналогичную операцию с верхней частью изображения. 

Удалите лишнюю часть угла 

 
3.     Добавьте нужный текст и картинки 
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4.     Теперь с помощью фильтра Render > 3D-Transform создадим куб, на который потом 

наклеим нашу обложку. 

Выберите инструмент Cube Tool (Куб) и нарисуйте куб, затем выберите инструмент 

Selection Tool (Стрелка), с его помощью «схватитесь» и потяните за левую нижнюю точку 

куба, с этой областью следует проводить дальнейшие манипуляции 

 
5.     Инструментом Trackball Tool (Ориентация) разверните куб таким образом, чтобы 

каждая из трех сторон имело свой оттенок серого. Если какая-то часть окажется 

прозрачной, вернитесь к использованию Selection Tool и измените положение левой 

нижней точки 

 
6.     Теперь переместите все слои с обложками на изображение с кубом и с помощью 

трансформации наложите их поверх 
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7.     Для завершения композиции, выделите половину верхней части коробки, вырежьте на 

новый слой и примените стиль Drop Shadow (Тень) 

 

 

Задание 10. Имитация объема. Металлическое кольцо 

1.     Создайте новое изображение RGB. Заполните фон черным цветом. Теперь возьмите 

направляющие сверху и слева и установите их в центре изображения. У вас должно 

получиться перекрестие как на рисунке. Создайте новый слой. 

 
2.     Возьмите инструмент «выделение круга» и установите перекрестие в точке пересечения 

направляющих линий. Удерживая ALT+SHIFT нажмите и создайте круг. Залейте круг 
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серым. Повторите этот пункт, но сделайте второй круг немного меньшего диаметра. 

Теперь нажмите DEL для вырезания меньшего диаметра. Отмените выделение. У вас 

должно получиться серое кольцо. 

 
3.     Выделите кольцо и создайте новый канал на основе выделения. Залейте выбранную 

область белым цветом и отмените его выбор. В канале производим Смазывание Гаусса: 

первым проходом используем фильтр 4, затем 3, а потом 2. 

 
4.     На слое с кольцом Фильтр > Render > Lighting effects. В "texture channel" выберите 

новый канал. Подобрать параметры. 

 
5.     Разглаживаем края кольца. Выделяеем его, сглаживаем границы на 1 пкс, инвертируем 

выбор, нажимаем DEL. 

6.     Настраиваем кривые. 

 
7.     Получаем: 
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Задание 11. Имитация объема. Металлический провод 

1.     Создаем новое изображение, 250x250 пикселей, RGB. В качестве цвета основного фона 

выбираем темно-серый. Теперь создаем новый Слой и с помощью кисти рисуем линию 

требуемой формы шириной 15 пикселей. Назовем слой Wire. 

 
2.     Сделаем копию слоя Wire путем его перетаскивания на пиктограмму кнопки Новый 

Слой. Переименуем новый слой в Cut Wire. 

3.     Теперь спрячем слой Wire, щелкнув на пиктограмме глаза, на панели Слои. Этот слой 

нам пригодится немного позже. 

4.     Сейчас выберем инструмент Ластик, определим размер кисти в пределах 5 пикселей и с 

его помощью придадим кривой вид, показанный на рисунке. 

 
5.     Удерживая Ctrl, кликаем по невидимому слою Wire в панели Слои. Таким образом 

создадим выделение, не принимая во внимание прозрачность слоя Wire. 

6.     Перейдем затем к панели Каналы и там сохраним созданное выделение. Переходим на 

этот канал. 

 
7.     Применим к каналу фильтр Смазывание Гаусса с опцией Радиус сначала 9 пикселей, 

затем 6, затем 3 пикселя, и, наконец, 1 пиксел. 

8.     Применим теперь к выделению АвтоУровни. 

9.     Вернемся на панель Слои (Layers), и, удерживая Ctrl кликнем на слое Cut Wire, чтобы 

выбрать его прозрачность. Затем опять переходим к панели Каналы, кликаем на новом 

канале, инвертируем выделение, и в конце концов очистим выделение, нажав Del. Уберем 

выделение. 
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10. Вернемся к панели Слои и сделаем активным слой Cut Wire. 

11. Откроем диалоговое окно Lightning Effects (Фильтр > Render > Lighting 

Effects)... Создадим белый направленный свет (Directional light) сверху вниз - из правого 

верхнего угла, - как показано на рисунке. Затем создадим направленный свет снизу вверх - 

из левого нижнего (источник света копируется с Alt). 

 
12. Определим примерные параметры: 

Глянец (Gloss): 100 Яркий (Shiny) 

Материал (Material): -100 Пластик (Plastic) 

Экспозиция (Exposure): 39 

Среда (Ambience): -21 

Установим Текстурный Канал (Texture Channel) в позицию Альфа1 и определим его 

высоту в размере 15. Теперь установим направление освещения таким образом, чтобы 

достичь наиболее желаемого эффекта. 

13. Подкрашиваем с помощью Цветового баланса или Тона/Насыщенности. 

 
14. Сделаем видимым слой Wire. Еще раз кликнем на нем, удерживая Ctrl, чтобы сделать 

выделение. 

15. Чтобы сделать линию на 1 пиксель тоньше, инвертируем выделение, затем сжимаем 

выделение на 1 пиксель, очищаем выделение – Del, убираем выделение. 

16. И последний шаг: Фильтр > Render > Lighting Effects... 

Установим Текстурный Канал (Texture Channel) на Wire Прозрачность. 

17. Добавляем по усмотрению эффект Тени. 
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Лабораторная работа №6 

Тема: Обработка фотографий 

Задание 1. Клонирование в перспективе 

1.     Открываем фотографию. Наша задача - удалить собаку таким образом, чтобы 

сохранилась дорога в ее истинном виде 

 
2.     Создайте новый слой. 

Filter > Vanishing Point (Alt+Ctrl+V). Прежде всего нужно задать угол перспективы с 

помощью инструмента Create Plane tool. Щелкните там, где хотите начать и продолжайте 

щелчки под нужными вам углами, аналогично использованию инструмента Polygonal 

Lasso. 

Если перспектива задана правильно, появится сетка голубых оттенков, в противном 

случае сетка будет желтого цвета. По завершении расстановок точек, может оказаться так, 

что вы не угадали изначально с шириной. Инструментом Edit Plane Tool можно 

редактировать получившуюся сетку. Если сетка поменяет свой цвет на красный, значит 

перспектива построена неверно 

 
3.     Теперь выберите Stamp Tool. Сетка в центре сразу пропадет. Как и при работе с Clone 

Stamp, сначала нужно задать образец, т.е. источник, который будет использоваться при 

клонировании. Для этого щелкните в нужном месте, удерживая клавишу Alt. Потом 

зарисовывайте удаляемый нами объект. При клонировании будет сохраняться эффект 

перспективы. Для реалистичности лучше почаще задавать новые образцы. 

По завершении нажмите кнопку Ok. Отклонированная часть будет располагаться на 

отдельном слое 
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Задание 2. Колоризация ч/б фото 

1.     Откроем нужную фотографию 

 
2.     Перейдите в цветовой режим RGB. 

Создайте новый слой, залейте его белым. Режим наложения слоев измените на Multiply 

(Умножение) 

 
3.     Выберите зеленый цвет и мягкой кистью закрасьте кожу 

 
4.     Ластиком сотрите краску с губ, глаз и т.д. 

 
5.     Создайте новый слой, установите режим наложения слоев Multiply и закрасьте волосы 
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6.     Добавьте цвета левому мужчине 

 

Задание 3. Повышение резкости 

1.     Откроем нужную фотографию 

 
2.     Скопируем слой, обесцветим его (Ctrl+Shift+U) 

 
3.     Создадим еще одну копию слоя и проинвертируем на нем цвета (Ctrl+I) 

 
4.     К верхнему слою примените режим смешивания Vivid Light, потом Filter > Blur > 

Gaussian Blur, примерно на 3 

 
5.     Объедините два верхних слоя, примените режим смешивания Vivid Light 
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Задание 4. Смягчение фокуса 

1.     Откроем нужную фотографию 

 
2.     Создадим копию слоя и обесцветим его (Ctrl+Shift+U) 

 
3.     Image > Adjustment > Posterize, примерно на 7. 

Примените режим смешивания Overlay 

 
4.     Filter > Blur > Gaussian Blur, примерно на 5 

 

Задание 7. Винтажный снимок 

1.     Откройте нужную фотографию 
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2.     Откройте палитру слоев, два раза щелкните по слою Background, после чего в 

появившемся диалоговом окне нажмите ОК. Теперь Background превратился в обычный 

слой 

3.     Добавьте немного шума: Filter > Noise > Add noise (Amount: 6%, Distribution: Gaussian, 

Monochromatic) 

4.     Наступило время убрать цвета с фото и добавить оттенок сепии. Внизу палитры слоев 

нажмите кнопку Add Adjustement Layers 

 
и выберите Hue/Saturation (Hue: 23, Saturation: 13, Lightness: 0, Colorize отмечено) 

 
5.     Наше фото слишком чистое и неповреждѐнное. Давайте сделаем его более грубым. 

Создайте новый слой (Ctrl+Shift+N), прямоугольным выделением (M) выделите верхнюю 

половину изображения и залейте цветом #A99A90. 

Теперь Filter > Тexture > Grain (Intensity: 40, Contrast: 50, Grain Type: Vertical). 

Далее Filter > Brush Strokes > Spatter (Spray Radius: 10, Smoothness: 5) 
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Теперь трансформируйте новый слой так, чтобы он закрыл картинку полностью. 

Перейдите в палитру слоев, установите режим смешивания Soft Light и прозрачность 

примерно 60% 

 
6.     Теперь добавим эффект перегиба. 

Переключитесь в палитру каналов и создайте новый канал. Выберите Gradient tool (G). 

Переместитесь в панель опций и установите градиент Foreground to background, Reflective, 

Lighten mode. 

 
Сделайте полоску в одном из углов. 

 
Ctrl+левая кнопка мыши по каналу Alpha1, после чего выберите RGB канал. Идѐм в Edit > 

Copy Merged (Shift+Ctrl+C). Потом - Edit > Paste (Ctrl+V). Теперь добавим к новому слою 

стиль. Для этого нужно дважды щѐлкнуть по слою в палитре слоѐв или нажать 

соответствующую кнопку внизу. Выберите Bevel&Emboss и примените следующие 

настройки: 
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Уменьшим прозрачность слоя с перегибом примерно до 50%. Поднастроим параметры 

других слоев по вкусу 

 

Задание 8. Эффект старого фото 

1.     Откройте любую фотографию 

 
2.     Создайте слой с радиальным градиентом от прозрачного до полупрозрачного черного. 

Продублируйте этот слой 

 
3.     Измените режим смешивания обоих градиентов на Soft light 

4.     Добавьте слой настроек с кривыми Curves 
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и настройте его 

 
5.     Подберите старящую текстуру, перетяните в наше фото верхним слоем 

 
6.     Обесцветьте этот слой: Image > Adjustments > Desaturate и поставьте ему режим 

наложения Hard light, подберите прозрачность слоя 

 
7.     Создайте новый слой. Поставьте цвет переднего плана #f5a700 и кистью сделайте 
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несколько линий 

 
8.     Размойте этот слой: Filter>Blur>Motion Blur (Angle -90, Distance 999) 

 
9.     Поставьте режим наложения Vivid light 

 

Задание 9. Из цветного в триколор 

1.     Откроем нужную фотографию 

 
2.     Выделим нужный фрагмент и скопируем на новый слой. Исходный слой можно удалить 
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3.     Создаем новый слой и на нем выделяем фрагмент серым 

 
4.     Отключаем видимость серого слоя. На слое с нашим фрагментом выделяем темные 

участки: Select>Color Range, Shadows 

 
5.     Создаем новый слой и на нем заливаем выделение черным 

 
6.     Отключаем также видимость слоя с темными участками. На слое с нашим фрагментом 

выделяем светлые участки: Select>Color Range, Lights. Создаем новый слой и на нем 

заливаем выделение белым 

 
7.     Теперь включаем видимость чѐрного и серого слоѐв 
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8.     Теперь можно по желанию добавить фон, тонировать изображение и т.п. 

 

Задание 10. Имитация живописи. Подсолнухи а'ля Ван Гог 

1.     Откройте исходную фотографию 

 
2.     Замена холодного темного фона на более теплые оттенки. 

Выделите фон Волшебной Палочкой. Для удобства можно использовать только один 

канал, а также работать с маской. Не снимая выделения создайте новый слой, добавьте к 

нему маску, снимите значок цепочки в палитре слоев между пиктограммой слоя и маски. 

Этот слой будет использоваться для рисования фона, а маска должна защитить сам букет. 

Залейте верхний слой цветом #64ACA1 

10. Добавьте рамку, подберите к ней стили 
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Задание 11. Преобразуем фото в картину 

1.     Откроем нужную фотографию 

 
2.     Создаем 3 копии фонового слоя, отключаем видимость двух верхних, встаем на второй 

снизу слой 

3.     Filter > Artistic > Palette Knife (6, 3, 0). 

Потом Image > Adjust > Hue/Saturation (0, 70, 5. Без Colorize) и Filter > Blur > Gaussian Blur 

(радиус 4,0) 

 
4.     Сделайте активным второй слой, который мы дублировали. Filter > Artistic > Dry Brush 

(2, 8, 1) 
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5.     Сделайте активным третий слой, который мы дублировали. Filter > Blur > Smart Blur (15, 

50, Low, Edge Only). 

Сейчас изображение выглядит как белые линии по черному фону. Теперь, необходимо 

сделать инверсию (Ctrl+I) для получения эффекта «черным по белому» 

 
6.     Для усиления эффекта рисунка можно применить Filter > Artistic > Poster Edges (2, 1, 2) 

 
7.     Изменяем режим смешивания всех сдублированных слоев на Soft Light 

1.     Откроем нужную фотографию 
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2.     Обесцветим ее (Ctrl+Shift+U) 

 
3.     Filter > Custom > High Pass, радиус примерно 4 

 
4.     Скопируйте слой, примените режим смешивания Color Dodge. Увеличьте контраст: 

Image > Adjustment > Brightness/Contrast 

 
5.     Filter > Blur > Smart Blur (примерные параметры: Radius 20, Threshold 30) 

 

Задание 13. Плакат в стиле шестидесятых 

1.     Создайте новый документ для постера любого размера. На новом слое кистью создаем 
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кривые сектора для текстов и изображения 

 
2.     Залейте фон желто-оранжевым. Создайте на новом слое контур с помощью Rounded 

Rectangle Tool. Загрузите его как выделение и залейте фиолетовым 

 
3.     Добавьте текст, растрируйте его и подгоните размеры 

 
4.     Деформируем текст так, что бы он соответствовал сектору: Edit > Transform > Warp. 
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Подгоняем весь текст постера под отведенные ему секторы 

 
5.     Меняйте цвет и другие параметры текста. Вместо некоторых надписей оставьте их 

обводку 

 
6.     Добавим эффект от старой печати. 

Скопируйте слой с текстом, залейте его вторичным цветом и сдвиньте вниз и вправо 

8.     Добавим в наш плакат фотографию 

 
9.     Превратим фотографию в постер. 
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Обесцветьте, потом Image > Adjustment > Posterize. Получив несколько цветов, залейте их 

 
10. Перенесите постер в наш плакат под слой с текстурой, трасформируйте, при 

необходимости доработайте ластиком 

 

Задание 14. Монета 

1.     Создаем новое изображение 500 x 500 с прозрачным фоном. На новом слое создаем 

круглое выделение по центру и заливаем его серым (#C2C2C2) 

 
2.     Для создания кромки монеты уменьшаем выделение на 10 пкс (Select > Modify > 

Contract), инвертируем выделение (Ctrl+Shift+I) и вырезаем получившийся край на новый 

слой. Применяем к новому слою стиль Bevel and Emboss, настраиваем 
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3.     Откройте изображение, которое вы будете использовать в качестве портрета для вашей 

монеты 

 
и превратите его в эскиз по алгоритму, приведенному в задании Преобразуем фото в 

эскиз (Задание 12) 

 
4.     Перенесите нужный фрагмент эскиза в монету, выделите на нем оттенки белого (Select > 

Color Range) и удалите их. К слою с оставшимися контурами примените стиль Bevel and 

Emboss и настройте 

 
5.     Добавьте текст. Для его искажения используйте кнопку Create warped text на панели 

настроек. Примените стиль Bevel and Emboss и настройте 
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6.     Добавляем по вкусу цвета, тени, текстуры и т.п. 

 
Лабораторная работа №7 

Тема: Рисование 

Задание 1. Сердце 

1.     Создать новый документ 800x600 с белым фоном 

2.     Делаем круглую выделенную область, на вкладке Paths кнопкой Make work path from 

selection преобразуем выделение в векторный контур 

 
3.     С помощью инструментов для работы векторной графикой Convert Point Tool, Direct 

Selection Tool, Path Selection Tool и т.д. превращаем круглый контур в сердце 

 
4.     На вкладке Paths кнопкой Load path as a selection преобразуем векторный контур 

обратно в выделение 

5.     Создаем для сердца новый слой, заливаем его красным 

6.     Из палитры Color-Swatches-Styles используйте встроенный стиль Голубое стекло 

(Кнопка) для объема 

7.     В палитре слоев меняем стили: Color Overlay установить красным; в Inner Glow 

понизить Opacity до 30%; в разделе Bevel and Emboss в настройке Shading поставить 

Angle=150 Altitude=64. Добавить стиль Outer Glow для размытия 
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Задание 2. 3D - Смайлик 

1.     Создайте новый документ 500х500 с серым фоном. На новом слое создайте белый круг с 

обводкой шириной 2 рх и цветом #B59605 

 
2.     Примените к окружности нормальный линейный градиент снизу вверх 

 
Цвета слева направо: #D8D635 -> #FFE617 -> D6AD00 

 
3.     На новом слое создайте выделение, на 3 рх меньшее основной окружности, и закрасьте 

его верхнюю часть белой мягкой кистью 

 
4.     Уменьшите прозрачность верхнего слоя 
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5.     Для глаза создайте новый слой с белой заливкой 

 
6.     Залейте глаз серо-белым градиентом, примените обводку шириной 2 рх и цветом 

#B59605, добавьте белый штрих. 

Скопируйте глаз и отразите его по горизонтали 

 
7.     На разных слоях нарисуйте брови, глаза и рот. Используйте такие эффекты слоя, как 

Тени, Свечения, Рельефность и т.п. Можно добавить несколько штрихов 

 

Задание 3. CD 

1.     Создайте новое изображение размером 400 х 400 с белым фоном. Установите 

вспомогательные линии ровно по середине (включите линейку Ctrl+R). Создайте новый 

слой 

2.     Выделите из центра (удерживая Shift и Alt) окружность 340 х 340. Установите 

режим «Вычитание из выделенной области» и выделите окружность 44 х 44. 

Получившуюся фигуру залейте цветом #E5E5E5 
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3.     Из центра диска вычтите окружность 106 х 106, полученную область вырежите на 

новый слой. К слою примените стиль Gradient Overlay (цвета градиента: от #CCCCCC к 

#526577) 

 

 
4.     Выделите правую половину изображения и на новом слое примените градиент Spectrum 

 
5.     Примените к этому слою трансформацию в режиме перспективы, передвиньте верхний 

левый узелок к центру 
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6.     Продублируйте этот слой, копию отразите по горизонтали. Объедините эти два слоя, 

продублируйте, копию поверните на 90 градусов. Объедините эти два слоя, к 

получившемуся слою примените стиль наложения Overlay, прозрачность слоя 70% 

 
7.     Создайте новый корректирующий слой Hue/Saturation (Цветовой тон/Насыщенность) с 

прозрачностью 30% и следующими настройками: Colorize, Hue: 227, Saturation: 44, 

Lightness: -8 

 
8.     Выделите в центре слоя со спектральным градиентом окружность диаметром 132 

пикселя и вырежете ее на новый слой. Примените к нему режим наложения Screen, 

прозрачность 60% 

 
9.     Примените к некоторым слоям стиль Обводка, настройте параметры 
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Задание 4. Печать 

1.     Создайте новый документ 300х300 с белым фоном. Напишите недлинную строчку 

текста 

 
2.     Выделите слой с текстом, инструмент Text и щелкните на панели вверху по кнопке с 

буквой Т и дугой под ней. Установите следующие значения 

 
3.     Скопируйте слой и поверните копию на 180 градусов (Edit > Transform > Rotate 180). 

Переместите копию так, чтобы она располагалась под оригиналом 

 
4.     Создайте новый слой. Выделите область с текстом инструментм Elliptical Marquee. 

Затем Edit > Stroke > 5px черного цвета 

 
5.     Повторите действие, только уже с окружностью поменьше 
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6.     На новом слое напишите нужный тест или даже какое-нибудь изображение для центра 

печати 

 
7.     Создайте новый слой поверх остальных. Поставьте цвета по умолчанию (кнопка D), 

добавьте облаков Filter > Render > Clouds, а затем Filter > Noise > Add Noise 

 
8.     Выделите полученный слой с зашумленными облаками и смените его режим 

смешивания на Screen 

 
9.     При желании поверните немного всю печать: сведите слои и Image > Rotate Canvas > 

Arbitrary... 
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Задание 6. Клейкий листок для заметок 

1.     Создаем новый документ, заливаем фон любым цветом или картинкой. Можно 

использовать Layer Styles 

 
2.     Выберите инструмент Pen в режиме Paths. Создайте новый слой, а на нем подобную 

фигуру 

 
3.     Заполните контур белым, кликнув на нем правой кнопкой мыши и выбрав пункт «Fill 

Path» 
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4.     Удалите контур. Добавьте Layer Styles со следующими настройками: 

 

 

 

 
Ваш клейкий листок сейчас должен выглядеть примерно так: 



67  

 
5.     Добавьте немного текста на наш листок, поверните текст вправо на несколько градусов, 

чтобы его угол совпадал с углом наклона листка 

 
 

 

 
 

 

Лабораторная работа 1: Основы работы с Figma и создание простого 

макета сайта 

Цель: Ознакомиться с интерфейсом Figma и научиться создавать простые 

макеты веб-страниц для понимания процесса дизайна интерфейсов. 

 
1. Создание нового проекта и подготовка рабочего пространства 

1. Регистрация и вход в Figma: 

o Перейдите на сайт Figma. 

o Зарегистрируйтесь, если у вас нет аккаунта, или войдите в 

существующий аккаунт. 

2. Создание нового файла: 

o После входа в Figma выберите кнопку New File в правом верхнем 

углу. 

o Это откроет новый рабочий документ, где вы будете создавать свой 

макет. 

3. Выбор фрейма (Frame): 

https://www.figma.com/
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o В Figma вместо обычных "артбордов" используется Frame. В 

панели инструментов выберите инструмент Frame или нажмите 

клавишу F. 

o В Figma есть предустановленные размеры для различных устройств 

(например, для десктопа, планшетов, мобильных устройств). Для 

этой лабораторной работы выберите Desktop (1440x1024), так как 

мы создаем макет для десктопной версии сайта. 

2. Создание элементов макета 

1. Добавление логотипа: 

o Нарисуйте простую фигуру в виде круга с помощью инструмента 

Ellipse (O), чтобы сделать логотип. 

o Залейте его цветом, например, синим или зеленым. 

o Добавьте текст в логотип с помощью инструмента Text (T) и 

напишите название вашего сайта или компании, например, "My 

Website". 

2. Создание навигационного меню: 

o Нарисуйте прямоугольник с помощью инструмента Rectangle (R), 

который будет фоном для меню. Задайте высоту 60px и ширину 

1440px. 

o Разместите этот прямоугольник в верхней части фрейма. 

o Используя инструмент Text (T), добавьте элементы навигации: 

"Главная", "О нас", "Контакты". Расположите их горизонтально в 

меню. 

3. Добавление главного баннера: 

o Нарисуйте прямоугольник с размерами 1440px на 400px. Это будет 

ваш главный баннер на странице. 

o Залейте его изображением (можно взять картинку с вашего 

компьютера и загрузить еѐ в Figma с помощью Place Image). 

Например, используйте изображение с пейзажем или фотографию, 

соответствующую теме сайта. 

4. Создание блоков с контентом: 

o Нарисуйте несколько прямоугольников, которые будут 

представлять собой карточки с контентом (например, для блоков с 

товарами, услугами или информацией). 

o Для этого используйте инструмент Rectangle (R) с размерами 

400x300px. Эти блоки будут располагаться под баннером. 

5. Добавление кнопок: 

o Нарисуйте небольшие прямоугольники с закругленными углами 

для кнопок (например, "Купить", "Подробнее"). 

o С помощью инструмента Text (T) добавьте текст на кнопку, 

например, "Подробнее". 

3. Применение стилей и выравнивание 

1. Настройка цветов и стилей: 
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o Для фона, кнопок и текста используйте основные цвета, 

соответствующие вашему дизайну. Выберите 2-3 основных цвета 

для сайта. 

o Задайте стиль для текста: выберите шрифт (например, Arial, 

Roboto) и настройте его размер, жирность, межстрочное 

расстояние. 

o Чтобы не делать это вручную для каждого элемента, создайте 

стили для текста и цветов. Для этого выберите текстовый элемент, 

нажмите на иконку стилистического меню и создайте новый стиль. 

2. Выравнивание элементов: 

o Для выравнивания элементов можно использовать инструменты 

выравнивания в верхней панели Figma. Убедитесь, что все 

элементы (текст, кнопки, блоки) выровнены по сетке или 

относительно друг друга. 

o Например, вы можете выровнять меню по центру, а баннер 

растянуть на всю ширину страницы. 

3. Использование направляющих: 

o Чтобы точно выровнять элементы на странице, вы можете 

использовать направляющие. Для этого перетащите их с верхней и 

левой панели, чтобы выровнять элементы по вертикали и 

горизонтали. 

4. Создание прототипа страницы (интерактивность) 

1. Настройка переходов: 

o Для того, чтобы ваш макет был интерактивным, вам нужно 

настроить прототип. 

o Переключитесь на вкладку Prototype в правом верхнем углу. 

o Создайте взаимодействие, например, переход на другую страницу 

при клике на кнопку "Подробнее". Для этого выделите кнопку, 

нажмите на маленький круг в правом верхнем углу и протяните его 

к следующей странице или фрейму. 

2. Тестирование прототипа: 

o Нажмите на кнопку Present в правом верхнем углу Figma, чтобы 

протестировать свой прототип. 

o Убедитесь, что кнопки и переходы работают как ожидалось. 

5. Экспорт макета 

1. Подготовка к экспортированию: 

o Когда вы завершите макет, его можно экспортировать. 

o Выберите фрейм или отдельные элементы, которые хотите 

экспортировать, и нажмите правой кнопкой мыши. Затем выберите 

Export. 

o Укажите формат файла, например, PNG или PDF, и нажмите 

Export. 

2. Сохранение проекта: 
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o Не забывайте сохранять проект, чтобы он был доступен для 

дальнейшей работы. В Figma проект сохраняется автоматически, но 

вы можете также экспортировать файл, чтобы передать его 

коллегам или преподавателю. 

 
6. Завершающий этап 

 Проверьте, что все элементы размещены правильно, а текст читаем. 

Убедитесь, что страницы не перегружены информацией и выглядят 

аккуратно. 

 Пересмотрите макет на предмет выравнивания и правильного 

использования цветов и шрифтов. 

 Подготовьте макет для сдачи, экспортируя его в необходимом формате 

(например, PNG или PDF), если нужно. 

 
Ресурсы для углубленного изучения 

 Онлайн-курс: Основы дизайна интерфейсов в Figma на Coursera 

 Книга: "Дизайн как искусство" Дэвида Кэди (представление принципов 

дизайна и композиции) 

 Сайт: Color Theory — теоретические основы использования цвета в 

дизайне 

 

 

Лабораторная работа 2: Создание макета мобильного приложения в 

Figma 

Цель: Научиться создавать мобильный макет для приложения с 

использованием Figma, освоить принципы адаптивного дизайна и разработку 

интерфейсов для мобильных устройств. 

 
1. Создание нового проекта и подготовка рабочего пространства 

1. Открытие Figma и создание нового файла: 

o Перейдите на сайт Figma, если не сделали этого ранее. 

o Войдите в свой аккаунт и создайте новый проект, кликнув на 

кнопку New File в правом верхнем углу. 

o Это откроет пустую рабочую область, где вы будете создавать 

макет мобильного приложения. 

2. Выбор фрейма для мобильного устройства: 

o В Figma используйте Frame для создания рабочего пространства. 

Выберите инструмент Frame (или нажмите клавишу F). 

o В панели справа выберите шаблон для мобильного устройства 

(например, iPhone 11/12/13 или Pixel 5). Эти размеры 

предустановлены в Figma и подходят для создания макетов 

мобильных приложений. 

o Размеры фрейма для iPhone 11 составляют 375 x 812 px (ширина x 

высота), что соответствует стандартному размеру экрана. 

https://www.coursera.org/learn/figma-interfaces
https://www.figma.com/
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2. Создание структуры приложения 

1. Добавление верхней панели (Header): 

o Нарисуйте прямоугольник для верхней панели с помощью 

инструмента Rectangle (R). Установите размеры 375x100px для 

ширины и высоты. 

o Расположите панель в верхней части экрана. 

o Задайте ей темный фон (например, #333333) и добавьте на нее 

элементы, такие как логотип и иконку меню. 

 Используйте инструмент Text (T), чтобы написать название 

вашего приложения (например, "AppName"). 

 Нарисуйте иконку меню в виде трех горизонтальных линий 

(гамбургер-меню) с помощью инструмента Line или 

используйте готовую иконку. 

2. Добавление основного контента: 

o Разделите экран на несколько блоков. Для этого нарисуйте 

несколько прямоугольников, которые будут служить контейнерами 

для контента. 

 Например, добавьте блок с изображением или картинкой, 

которая будет служить баннером. 

 Размер изображения может быть 375 x 200 px (ширина x 

высота). 

3. Создание кнопок (CTA - Call to Action): 

o Нарисуйте прямоугольники для кнопок с закругленными углами. 

Эти кнопки могут быть использованы для переходов в другие части 

приложения. 

o Для этого используйте инструмент Rectangle (R) и установите 

радиус углов для кнопки (например, 20px), чтобы она выглядела 

как современная кнопка. 

o Залейте кнопку цветом (например, #007BFF для синего цвета) и 

добавьте текст с помощью инструмента Text (T). Например, кнопка 

"Подробнее", "Перейти" или "Регистрация". 

4. Добавление списка элементов: 

o Создайте список карточек, которые будут отображаться в 

приложении. Например, это могут быть карточки с товарами или 

услугами. 

o Для этого используйте прямоугольники размером 375x150px. 

Внутри каждого прямоугольника добавьте текст, изображение и 

цену, чтобы имитировать карточку товара. 

 Используйте инструмент Text (T) для добавления названия и 

описания товара. 

 Для изображения используйте Place Image и загрузите 

картинку с вашего устройства. 

3. Применение стилей и выравнивание 

1. Настройка цветов и шрифтов: 
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o Убедитесь, что все элементы соответствуют цветовой палитре 

вашего приложения. Используйте 2-3 основных цвета для фона, 

кнопок и текста. 

o Настройте шрифты: выберите подходящий шрифт (например, 

Roboto, Helvetica Neue) и установите размер шрифта для 

заголовков, основного текста и кнопок. 

2. Выравнивание элементов: 

o Для правильного выравнивания используйте инструменты 

выравнивания в верхней панели Figma (например, выравнивание по 

центру, по левому краю и т.д.). 

o Все элементы должны быть выровнены по сетке или относительно 

друг друга, чтобы макет выглядел аккуратно и гармонично. 

3. Использование направляющих и сетки: 

o Включите сетку, чтобы помочь выравнивать элементы на экране. 

Для этого откройте Layout Grid в правой панели Figma и выберите 

тип сетки (например, Column Grid или Rows Grid). 

o Направляющие и сетки помогут вам точно размещать элементы на 

странице, обеспечивая симметричность и соответствие 

дизайнерским стандартам. 

4. Создание прототипа и интерактивности 

1. Добавление переходов между экранами: 

o Переключитесь на вкладку Prototype в правой панели. 

o Добавьте интерактивность: например, к кнопке "Подробнее" 

настройте переход на другой экран с подробной информацией о 

товаре или услуге. 

 Для этого выделите кнопку, затем в правом верхнем углу 

нажмите на маленький кружок и протяните его на другой 

экран. В настройках перехода выберите On Click и тип 

анимации (например, Instant или Dissolve). 

2. Тестирование прототипа: 

o Чтобы протестировать макет, нажмите на кнопку Present в правом 

верхнем углу. Это откроет режим презентации, в котором вы 

можете взаимодействовать с макетом, как с реальным 

приложением. 

o Убедитесь, что все кнопки работают корректно и переходы между 

экранами происходят без ошибок. 

5. Экспорт макета 

1. Экспорт изображения или макета: 

o Когда макет готов, его можно экспортировать. 

o Выберите элементы, которые хотите экспортировать, или весь 

фрейм, и нажмите Export в правом нижнем углу Figma. 

o Выберите формат файла (например, PNG, JPG) и нажмите Export. 

2. Подготовка к сдаче: 



73  

o Перед сдачей проекта убедитесь, что все элементы правильно 

выровнены и отображаются. 

o Экспортируйте макет в формате PNG или PDF, чтобы передать его 

преподавателю или коллегам. 

 
6. Завершающий этап 

 Проверьте, что все элементы макета расположены правильно, кнопки 

работают корректно, а весь текст читаем. 

 Убедитесь, что макет выглядит гармонично и соответствует требованиям 

мобильного интерфейса (например, наличие доступных кнопок и 

правильных размеров). 

 Экспортируйте макет и сохраните его в удобном для вас формате. 

 
Ресурсы для углубленного изучения 

 Онлайн-курс: Веб-дизайн для мобильных приложений на Coursera 

 Книга: "Мобильный дизайн. Руководство для профессионалов" 

(Эрик Мейер, Джошуа Дэвис) — книга о создании интерфейсов для 

мобильных устройств. 

 Сайт: Material Design Guidelines — официальные рекомендации от 

Google по созданию мобильных интерфейсов. 

 

 

Лабораторная работа 3: Создание адаптивного макета веб-сайта в 

Figma 

Цель: Научиться разрабатывать адаптивные (responsive) макеты для веб-

сайта, который будет корректно отображаться на различных устройствах 

(мобильных телефонах, планшетах и десктопах). 

 
1. Создание нового проекта и подготовка рабочего пространства 

1. Создание нового файла: 

o Откройте Figma и создайте новый файл, кликнув на кнопку New 

File. 

o Откроется пустой рабочий документ, где вы будете создавать 

адаптивный макет. 

2. Выбор фреймов для разных устройств: 

o В Figma создаются фреймы (Frames), которые будут представлять 

собой рабочие области для различных устройств. 

o Выберите инструмент Frame (F) в панели инструментов или 

нажмите F на клавиатуре. 

o В правой панели Figma выберите шаблоны для разных устройств. 

Начните с создания фреймов для трѐх популярных размеров 

экранов: 

 Desktop: 1440x1024 px 

 Tablet: 768x1024 px 

https://www.coursera.org/learn/mobile-web-design
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 Mobile: 375x667 px 

o Эти размеры фреймов станут основой для вашего адаптивного 

дизайна. 

2. Структура веб-страницы (Основные элементы) 

1. Создание базовых элементов страницы: 

o На каждом фрейме (Desktop, Tablet, Mobile) создайте основные 

элементы страницы: 

 Шапка (Header): Это верхняя панель с логотипом и 

навигацией. 

 Главный баннер: Большое изображение или слайдер, 

который будет размещен в верхней части страницы. 

 Блок контента: Разместите несколько карточек с товарами 

или услугами. 

 Подвал (Footer): В нижней части страницы разместите 

контактную информацию, ссылки на социальные сети и 

другие элементы. 

2. Рисуем Header (Шапку): 

o Используйте Rectangle (R) для создания фона шапки. Например, 

сделайте высоту 80px для Desktop, 60px для Tablet и 50px для 

Mobile. 

o Добавьте логотип с помощью инструмента Text (T) или создайте 

простую графику (например, круг или прямоугольник). 

o Добавьте элементы навигации — для Desktop и Tablet это могут 

быть горизонтальные ссылки, для Mobile — иконка меню 

(гамбургер). 

3. Главный баннер: 

o Для баннера используйте Rectangle (R) с размерами 1440x400 px 

для Desktop, 768x300 px для Tablet и 375x250 px для Mobile. 

o Залейте баннер изображением с помощью инструмента Place 

Image. 

o Выберите картинку, которая будет хорошо смотреться в различных 

разрешениях. 

4. Контент (карточки): 

o Нарисуйте прямоугольники для карточек. Для Desktop это могут 

быть 3 карточки по ширине экрана, для Tablet — 2, для Mobile — 1. 

o Каждая карточка будет содержать изображение, название и краткое 

описание. Используйте инструмент Text (T) для добавления текста 

и Place Image для вставки изображения. 

5. Подвал (Footer): 

o Нарисуйте прямоугольник для подвала с размерами 1440x120 px 

для Desktop, 768x100 px для Tablet и 375x80 px для Mobile. 

o В подвале добавьте текст с контактной информацией и ссылки на 

социальные сети. 

3. Применение стилей и выравнивание 
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1. Настройка цветов и шрифтов: 

o Для всех элементов выберите подходящие цвета. Например, 

используйте светлый фон и темный текст для легкости восприятия. 

o Настройте шрифты: для заголовков используйте более крупный 

шрифт (например, 24 px для Desktop, 20 px для Tablet, 16 px для 

Mobile), а для основного текста — меньше (например, 14 px для 

всех устройств). 

2. Использование стилей: 

o В Figma вы можете создавать стили для цветов и текста. Это 

позволяет вам быстро применять одинаковые стили ко всем 

элементам. 

 Выделите текст, настройте шрифт и размер, затем сохраните 

как стиль. Так вы сможете использовать его для всех 

заголовков на странице. 

 То же самое для цветов фона, текста, кнопок и других 

элементов. 

3. Выравнивание элементов: 

o Используйте инструменты выравнивания в Figma для того, 

чтобы все элементы страницы располагались симметрично. 

o Выравнивайте элементы по горизонтали и вертикали с помощью 

панелей выравнивания или включите Layout Grid (сетка), чтобы 

точно расположить элементы. 

4. Адаптация дизайна для разных устройств 

1. Адаптация для Desktop: 

o На фрейме Desktop создайте основной макет с широкими 

элементами: много информации, большие изображения и панели. 

o Сконцентрируйтесь на создании гармоничного и удобного 

интерфейса с достаточным количеством пространства для каждого 

элемента. 

2. Адаптация для Tablet: 

o Для Tablet уменьшите размер шрифтов и уменьшите количество 

информации в блоках. 

o Измените количество колонок: например, если на Desktop карточки 

размещаются в 3 колонки, на Tablet сделайте 2. 

o Убедитесь, что элементы не вылазят за края экрана и что дизайн 

выглядит компактно, но читаемо. 

3. Адаптация для Mobile: 

o На Mobile сделайте макет компактным и максимально 

упрощенным. 

o Уменьшите размеры изображений, уменьшите шрифт и обеспечьте, 

чтобы все важные элементы (например, кнопки и ссылки) легко 

нажимались пальцем. 

o Преобразуйте меню в гамбургер-меню, чтобы оно не занимало 

много места на экране. 
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o Убедитесь, что элементы имеют достаточно отступов, чтобы 

пользователь случайно не нажал на лишние кнопки. 

5. Прототипирование (интерактивность) 

1. Добавление взаимодействий между экранами: 

o Перейдите в вкладку Prototype в правой панели Figma. 

o Создайте интерактивные переходы между экранами: например, 

клик по кнопке в Header может открывать подменю или 

переходить на новую страницу. 

o Выберите элементы (например, кнопку), а затем нарисуйте 

соединительную линию на другие экраны (например, на экран с 

подробным описанием товара или услуги). 

2. Настройка переходов: 

o Убедитесь, что переходы между фреймами настроены корректно. 

Выберите On Click или While Hovering, если хотите, чтобы 

элементы реагировали на действия пользователя. 

o Проверьте, как выглядит сайт при переходах между экранами, 

чтобы убедиться в корректности адаптивности. 

6. Экспорт макета 

1. Экспорт элементов: 

o Когда макет готов, его нужно экспортировать для передачи другим 

участникам команды или преподавателю. 

o Выделите элементы, которые хотите экспортировать, и нажмите 

Export в правом нижнем углу. 

o Выберите формат файла (например, PNG, JPG, PDF) и укажите 

параметры экспорта. 

2. Экспорт прототипа: 

o Для тестирования и демонстрации макета вы можете 

экспортировать весь прототип в виде видео или в формате GIF. 

o Для этого нажмите на кнопку Present в правом верхнем углу, чтобы 

просмотреть взаимодействия, а затем используйте функцию записи 

экрана. 

 
Завершающий этап 

 Проверьте, как макет выглядит на разных устройствах и убедитесь, что он 

выглядит корректно. Убедитесь, что все элементы дизайна соответствуют 

требованиям адаптивного дизайна. 

 Экспортируйте макет и сохраните его в нужном формате (например, PNG 

или PDF). 

 
Ресурсы для углубленного изучения 

 Онлайн-курс: Responsive Web Design Fundamentals — курс по основам 

адаптивного дизайна. 

 Книга: "Не заставляйте меня думать. О проектировании удобных веб-

сайтов" Стива Круга — книга о принципах удобства использования. 
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 Сайт: A List Apart: Responsive Design — статьи по адаптивному дизайну. 

 

 

 

Лабораторная работа 4: Создание интерактивных элементов в Figma 

Цель: Научиться создавать и интегрировать интерактивные элементы 

(кнопки, формы, модальные окна и т.д.) в макет веб-сайта, используя Figma. 

 
1. Создание нового проекта и подготовка рабочего пространства 

1. Создание нового файла: 

o Откройте Figma и создайте новый файл, кликнув на кнопку New 

File. 

o На экране появится пустой рабочий документ. 

2. Выбор фреймов для проекта: 

o В качестве основы создайте фреймы для трех типов устройств: 

Desktop, Tablet и Mobile. 

o Для Desktop используйте размер 1440x1024 px, для Tablet — 

768x1024 px, для Mobile — 375x667 px. 

o Эти фреймы будут служить основой для вашего макета, и вы будете 

добавлять интерактивные элементы на них. 

 
2. Добавление интерактивных элементов (кнопок и форм) 

1. Создание кнопок: 

o Нарисуйте кнопку с помощью инструмента Rectangle (R). 

Например, создайте прямоугольник с размерами 200x50 px для 

Desktop, 180x50 px для Tablet и 150x40 px для Mobile. 

o Используйте стильный шрифт для текста на кнопке, например, 

Arial Bold, с размером шрифта 16px. 

o Разместите текст внутри кнопки, например, "Прочитать больше" 

или "Подписаться". 

o Добавьте стили для кнопки: 

 Залейте кнопки цветом (например, синий цвет #007BFF). 

 Установите скругления углов (например, 8 px). 

 Добавьте эффект наведения: при наведении кнопка должна 

немного изменять свой цвет, например, становиться темнее. 

2. Добавление формы для ввода данных: 

o Нарисуйте прямоугольники для полей ввода, например, для имени, 

email и сообщения. 

o Для каждого поля используйте Rectangle (R) с размерами 320x40 px 

для Desktop, 280x40 px для Tablet и 240x40 px для Mobile. 

o Внутри прямоугольников добавьте текстовые метки (например, 

"Имя", "Email") с помощью инструмента Text (T). 

o Добавьте кнопку Отправить под полями ввода. 

3. Создание выпадающего списка: 
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o Создайте выпадающий список с помощью Rectangle (R) и Text (T). 

o Нарисуйте прямоугольник с размерами 320x40 px для Desktop, 

280x40 px для Tablet и 240x40 px для Mobile. 

o Добавьте текст, например, "Выберите страну", чтобы показать, что 

это выпадающий список. 

o Для отображения раскрывающегося меню используйте Vector (P) 

для создания стрелочки. 

4. Создание радио-кнопок и чекбоксов: 

o Для радио-кнопок и чекбоксов создайте маленькие круги с 

помощью Ellipse (O). 

o Нарисуйте круг с размером 20x20 px для радио-кнопки и для 

чекбокса. 

o Добавьте текст рядом с каждым элементом, например, "Согласен с 

условиями" для чекбокса или "Мужчина/Женщина" для радио-

кнопки. 

 
3. Добавление модальных окон и взаимодействий 

1. Создание модального окна: 

o Модальные окна (или попапы) используются для отображения 

дополнительной информации без необходимости переходить на 

другую страницу. 

o Нарисуйте прямоугольник, который будет представлять само окно 

(например, размер 600x400 px для Desktop, 400x300 px для Tablet и 

300x250 px для Mobile). 

o Внутри окна добавьте заголовок с текстом, например, 

"Подтверждение", и текстовое описание, например, "Вы уверены, 

что хотите продолжить?". 

o Добавьте две кнопки внутри окна — например, "Да" и "Нет". 

Создайте кнопки аналогично предыдущим шагам (с 

прямоугольниками и текстами). 

2. Настройка модального окна для взаимодействия: 

o В Figma можно настроить переходы между экранами, чтобы 

имитировать открытие и закрытие модального окна. 

o Перейдите во вкладку Prototype в правой панели. 

o Выберите кнопку "Открыть окно" на главной странице и соедините 

еѐ с фреймом, на котором расположено модальное окно. Настройте 

переход On Click → Open Modal. 

o Для кнопки "Закрыть" в модальном окне создайте переход обратно, 

чтобы окно закрывалось при нажатии. 

 
4. Настройка интерактивности (прототипирование) 

1. Интерактивные кнопки: 

o Перейдите в режим Prototype для настройки переходов между 

экранами. 
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o Для кнопки "Прочитать больше" установите переход на новую 

страницу или фрейм с дополнительной информацией. Например, 

при нажатии на кнопку будет открываться фрейм с подробным 

описанием товара или услуги. 

o Настройте действия для кнопок, таких как On Hover (при 

наведении) или On Click (при клике). 

2. Интерактивность форм: 

o Для формы добавьте переходы, чтобы кнопка Отправить вела к 

фрейму с благодарностью за отправку данных. 

o Для поля ввода можно настроить изменения текста или фокуса на 

другом элементе. 

3. Использование горячих точек: 

o Создайте горячие точки (hotspots) на изображениях или кнопках. 

Это области, которые можно "кликать", и они будут действовать 

как элементы интерфейса. 

o Убедитесь, что все элементы с интерактивностью настроены так, 

чтобы пользователь мог взаимодействовать с интерфейсом, как 

если бы это был реальный веб-сайт. 

 
5. Экспорт и финальные шаги 

1. Экспорт макета: 

o Когда макет готов, его нужно экспортировать для демонстрации 

или передачи заказчику. 

o Выделите нужные элементы (например, кнопки, формы, модальные 

окна), затем нажмите Export в правом нижнем углу. 

o Экспортируйте макет в нужном формате (например, PNG, JPG или 

PDF) для последующего использования. 

2. Просмотр прототипа: 

o Чтобы протестировать интерактивные элементы, нажмите на 

Present в правом верхнем углу. 

o Просмотр будет демонстрировать ваш макет с настройками 

переходов и интерактивности. Убедитесь, что все элементы 

работают как задумано. 

o Для более подробного тестирования можете записать видео или 

GIF. 

 
Завершающий этап 

 Проверьте, как работают все интерактивные элементы в вашем макете: 

кнопки, формы, выпадающие списки, радио-кнопки и чекбоксы. 

 Убедитесь, что модальные окна открываются и закрываются правильно, а 

все формы отправляются на соответствующие страницы или показывают 

результат. 

 Экспортируйте проект и сохраните его для отправки или представления. 
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Ресурсы для углубленного изучения 

 Книга: "Don't Make Me Think" Стива Круга — книга о принципах 

удобства использования веб-сайтов, включая создание интерактивных 

элементов. 

 Онлайн-курс: Figma for Beginners — курс по изучению Figma, который 

охватывает создание интерактивных элементов. 

 

 

 

Раздел 2 Верстка страниц 

Работа 1 СОЗДАНИЯ КАРТОЧЕК ТОВАРОВ 

CSS (Cascading Style Sheets) — это каскадные таблицы стилей, которые используются для 

оформления HTML-элементов. С помощью CSS мы задаем внешний вид, такие как цвета, 

шрифты, размеры и расположение элементов на странице. 

CSS-селекторы позволяют выбирать элементы HTML, которые необходимо стилизовать. 

3. Основные CSS-свойства, используемые в этой работе: 

3.1. Свойство width и height 

 Свойства width (ширина) и height (высота) задают размер элемента. 

css 

Копировать код 

.card { 

    width: 250px; /* Ширина карточки */ 

    height: 300px; /* Высота карточки */ 

} 

o Значения можно задавать в пикселях (px), процентах (%) и других единицах 

измерения. 

3.2. Свойство padding 

 Свойство padding определяет внутренние отступы — пространство между 

содержимым элемента и его границей. 

css 

Копировать код 

.card { 

    padding: 15px; /* Внутренние отступы со всех сторон */ 

} 

o Можно задавать одинаковые отступы со всех сторон или различные значения 

для каждой стороны: 

css 

Копировать код 

padding: 10px 20px; /* 10px сверху/снизу, 20px слева/справа */ 

3.3. Свойство margin 
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 Свойство margin управляет внешними отступами — расстоянием между элементом и 

другими элементами. 

css 

Копировать код 

.card { 

    margin: 10px auto; /* 10px отступ сверху и снизу, авто-отступы по 

бокам для центрирования */ 

} 

3.4. Свойство background-color 

 Свойство background-color задает цвет фона элемента. 

css 

Копировать код 

.card { 

    background-color: #f8f8f8; /* Светло-серый фон */ 

} 

o Цвет можно задавать с помощью стандартных цветовых имен (например, red, 

green, blue), а также с помощью шестнадцатеричных значений (например, 

#f8f8f8). 

3.5. Свойство text-align 

 Свойство text-align управляет выравниванием текста внутри элемента. 

css 

Копировать код 

.card { 

    text-align: center; /* Выравнивание текста по центру */ 

} 

o Также можно использовать left для выравнивания по левому краю и right 

для выравнивания по правому краю. 

3.6. Свойство font-size 

 Свойство font-size задает размер шрифта текста. 

css 

Копировать код 

.card h2 { 

    font-size: 1.2em; /* Размер шрифта для заголовков */ 

} 

 

4. Как подключить CSS к HTML? 

Есть несколько способов подключить CSS-файл к HTML-документу: 

 Внешний файл CSS — наиболее распространенный способ: В HTML-документе в 

теге <head> добавляется ссылка на внешний CSS-файл: 

html 

Копировать код 

<link rel="stylesheet" href="styles.css"> 
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Этот способ позволяет использовать один CSS-файл для нескольких HTML-страниц. 

 Встроенные стили (inline) — стили добавляются непосредственно в теги: 

html 

Копировать код 

<p style="color: red;">Этот текст будет красным.</p> 

Этот способ подходит для единичных случаев, но не рекомендуется для больших 

проектов. 

 Встроенные стили в теге <style> — стили можно добавить в <head> внутри тега 

<style>, но этот метод также не подходит для крупных проектов: 

html 

Копировать код 

<style> 

    p { 

        color: red; 

    } 

</style> 

 

5. Как работать с кнопками? 

 Кнопка <button> — стандартный HTML-элемент для создания кнопок. В CSS можно 

настроить внешний вид кнопки, например: 

css 

Копировать код 

button { 

    padding: 10px 20px; /* Внутренние отступы */ 

    background-color: #007BFF; /* Синий фон */ 

    color: white; /* Белый цвет текста */ 

    border: none; /* Без рамки */ 

    cursor: pointer; /* Курсор в виде руки */ 

} 

button:hover { 

    background-color: #0056b3; /* Темно-синий цвет фона при наведении */ 

} 

 

Цель: 

Создать HTML-документ с тремя карточками товаров и применить минимальный набор 

стилей через CSS. 

 

Задание 

1. Создайте HTML-документ с тремя карточками товаров. 

В каждой карточке добавьте: 

o Название товара (h2); 

o Описание (p); 

o Кнопку (button) с текстом "Подробнее". 

2. Подключите внешний CSS-файл. 

3. Стилизуйте карточки так, чтобы: 
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o У всех карточек был одинаковый размер; 

o У каждой карточки был светло-серый фон; 

o Заголовок (h2) был чуть крупнее текста; 

o Кнопка имела стандартный вид. 

 

Примерный результат: 

 

 
 

Работа 2 Позиционирование элементов 

ЗАДАНИЕ «Яблоки и Корзины» 

Скачайте файлы cart_apples.html, cart_apples.сss в свою папку или на 

рабочий стол. 

Необходимо открыть файлы для работы. Создать div элементы и 

присвоить им классы стилей зеленого, желтого и гнилого яблок. Далее 

необходимо использовав теорию по позиционированию и файл cart_apples.css 

положить яблоки в советующие корзины. 

1. Откройте cart_apples.html в браузере, чтобы увидеть исходные блоки. 

2. Сконцентрируйтесь на блоке .overlay-box и его позиционировании. 

3. Используйте position: relative; для родительского блока .target-box (если 

необходимо). 

4. Используйте position: absolute; для блока .overlay-box. 

5. Используйте свойства top, right, bottom, left, чтобы точно 

спозиционировать .overlay-box внутри каждой рамки по очереди. 

6. Помните, что координаты 0,0 (top: 0; left: 0;) – это левый верхний угол 

родительского контейнера. 
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7. Переместите блок .overlay-box внутрь каждого .target-

box последовательно. 

8. Меняйте стили в cart_apples.css файле. 

9. Проверьте адаптивность макета и убедитесь, что все работает на разных 

размерах экрана. 

10. Постарайтесь понять, как работает позиционирование. Не просто 

скопируйте решение, а постарайтесь применить знания, полученные в 

гайде. 

 

 

 

 

Раздел 3 Разработка клиентской части информационных 

ресурсов 

 

JavaScript 

 
Лабораторная работа №1: Работа с переменными, типами данных и 

операторами 

Цель работы: 

Закрепить знания о переменных и их объявлении (var, let, const). 

Научиться работать с основными типами данных JavaScript 

(number, string, boolean, null, undefined, object, symbol). 

Понять принцип работы операторов (арифметические, сравнения, 

логические, присваивания). 

Применять изученные концепции на практике для решения простых задач. 

Задания для выполнения: 

Объявление переменных: 

Создайте переменные для хранения имени пользователя, его возраста 

и признака совершеннолетия. Используйте var, let и const для разных 

переменных, и объясните почему. 

Выведите значения этих переменных в консоль. 

Типы данных: 

Создайте переменные разных типов (число, строка, булево значение, 

null, undefined, объект, символ). 

Выведите тип каждой переменной в консоль, используя 

оператор typeof. 

Попробуйте преобразовать переменные разных типов (например, 

строку в число). Выведите результаты преобразования. 
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Арифметические операции: 

Создайте переменные для хранения двух чисел. 

Выполните над ними сложение, вычитание, умножение, деление и 

остаток от деления. 

Выведите результаты операций в консоль. 

Операторы сравнения и логические операторы: 

Создайте переменные для хранения двух значений (числа, строки или 

булевы значения). 

Выполните операции сравнения (==, ===, !=, !==, >, <, >=, <=) и 

выведите результаты в консоль. 

Используйте логические операторы (&&, ||, !) для создания сложных 

условий. Выведите результаты в консоль. 

Практическое задание: 

Создайте переменные для хранения ширины и высоты 

прямоугольника. 

Вычислите площадь и периметр прямоугольника. 

Выведите результаты в консоль. 

Контрольные вопросы: 

В чем разница между var, let и const? 

Какие типы данных есть в JavaScript? 

Как преобразовать переменную из одного типа в другой? 

Какие операторы сравнения и логические операторы вы знаете? 

Как использовать переменные и операторы для решения простых задач? 

 

Лабораторная работа №2: Условные операторы и циклы 

Цель работы: 

Научиться использовать условные операторы (if, else if, else, switch). 

Понять принцип работы циклов (for, while, do...while). 

Применять эти конструкции для реализации логики программ. 

Решать задачи, требующие повторения действий или ветвления. 

Задания для выполнения: 

Условные операторы: 

Создайте программу, которая проверяет, является ли введенное число 

положительным, отрицательным или нулем. Используйте if, else 

if, else. 

Создайте программу, которая определяет оценку студента на основе 

его балла (например, "отлично", "хорошо", "удовлетворительно", 

"неудовлетворительно"). Используйте switch. 

Циклы for: 

Выведите числа от 1 до 10, используя цикл for. 

Выведите все четные числа от 20 до 30, используя цикл for и условный 

оператор. 

Выведите таблицу умножения на 7 (от 1 до 10) с помощью цикла for. 

Циклы while и do...while: 
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Реализуйте программу, которая запрашивает у пользователя ввод 

числа до тех пор, пока не будет введено положительное число. 

Используйте цикл while. 

Реализуйте программу, которая будет выводить случайные числа от 1 

до 10 до тех пор, пока не выпадет число 7. Используйте 

цикл do...while. 

Практическое задание: 

Напишите программу, которая принимает от пользователя число и 

выводит все делители этого числа 

Напишите программу которая считает сумму всех чисел от 1 до 

введенного пользователем числа 

Используйте оба вида цикла и сравните результаты 

Контрольные вопросы: 

Когда следует использовать if, else if и else? 

В чем разница между switch и if? 

Когда лучше использовать цикл for, а когда while или do...while? 

Как прервать выполнение цикла? 

Как использовать циклы для решения задач? 

 

Лабораторная работа №3: Функции 

Цель работы: 

Понять концепцию функций и их роль в программировании. 

Научиться объявлять и вызывать функции. 

Изучить передачу аргументов в функции и возврат значений. 

Применять функции для разделения кода на логические блоки и его 

повторного использования. 

Познакомиться с рекурсивными функциями. 

Задания для выполнения: 

Объявление и вызов функций: 

Создайте функцию, которая принимает имя пользователя в качестве 

аргумента и выводит приветствие в консоль. 

Вызовите эту функцию несколько раз с разными именами. 

Функции с возвратом значений: 

Создайте функцию, которая принимает два числа в качестве 

аргументов и возвращает их сумму. 

Создайте функцию, которая принимает число в качестве аргумента и 

возвращает его квадрат. 

Выведите результаты работы этих функций в консоль. 

Рекурсивные функции: 

Создайте рекурсивную функцию для вычисления факториала числа. 

Проверьте еѐ работу, вызвав для различных чисел. 

Функции как аргументы: 

Создайте функцию, которая принимает массив чисел и функцию-

колбэк. 
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Используйте колбэк для обработки каждого элемента массива. 

Примените ее для вывода каждого элемента массива в консоль и для 

нахождения суммы элементов. 

Практическое задание: 

Создайте функцию, которая принимает строку и возвращает ее в 

обратном порядке 

Создайте функцию, которая вычисляет площадь круга, используя 

функции из предыдущих заданий 

Протестируйте эти функции 

Контрольные вопросы: 

Что такое функция и для чего она нужна? 

Как объявить и вызвать функцию? 

Как передать аргументы в функцию? 

Как вернуть значение из функции? 

Что такое рекурсивная функция? 

 

Лабораторная работа №4: Объекты 

Цель работы: 

Понять, что такое объекты в JavaScript и как они используются для хранения 

данных. 

Научиться создавать объекты и добавлять в них свойства. 

Изучить разные способы доступа к свойствам объекта. 

Познакомиться с методами объекта и ключевым словом this. 

Работать с массивами объектов. 

Задания для выполнения: 

Создание и свойства объектов: 

Создайте объект, представляющий пользователя (с 

полями name, age, email). 

Выведите все свойства объекта в консоль. 

Добавьте новое свойство в объект (например, city) и выведите 

измененный объект. 

Методы объекта: 

Добавьте в объект метод, который будет выводить приветствие, 

используя имя пользователя. 

Добавьте метод, который будет возвращать возраст пользователя. 

Вызовите эти методы у созданного объекта. 

Доступ к свойствам объекта: 

Попробуйте получить доступ к свойствам как через ., так и через [] 

Создайте массив объектов пользователей и выведите данные каждого 

пользователя в консоль. 

this: 

В методах объекта выведите this и посмотрите что он значит 

Добавьте новые методы, использующие this. 

Практическое задание: 
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Создайте объект, представляющий книгу с полями title, author, pages. 

Создайте метод, который будет выводить информацию о книге в 

формате "Название: ..., Автор: ..., страниц: ..." 

Создайте массив книг и выведите информацию о каждой книге. 

Контрольные вопросы: 

Что такое объект и зачем он нужен? 

Как создать объект в JavaScript? 

Как добавить, изменить и удалить свойства объекта? 

Что такое метод объекта и как его вызвать? 

Что означает this в методе объекта? 

 

Лабораторная работа №5: Массивы и методы массивов 

Цель работы: 

Понять, что такое массивы в JavaScript и как они используются для хранения 

коллекций данных. 

Научиться создавать массивы и добавлять в них элементы. 

Изучить методы массивов 

(push, pop, shift, unshift, splice, slice, concat, join, indexOf, includes, forEach, ma

p, filter, reduce, sort). 

Применять эти методы для обработки и преобразования массивов. 

Задания для выполнения: 

Создание массивов и добавление элементов: 

Создайте массив чисел и массив строк. 

Добавьте элементы в конец и в начало массива, 

используя push и unshift. 

Удалите элементы с конца и начала массива, используя pop и shift. 

Методы splice и slice: 

Используйте метод splice для добавления, удаления и замены 

элементов в массиве. 

Используйте метод slice для создания копии части массива. 

Методы concat, join, indexOf, includes: 

Объедините два массива в один, используя метод concat. 

Преобразуйте массив в строку, используя метод join. 

Найдите индекс элемента в массиве с помощью indexOf и проверьте 

наличие элемента с помощью includes. 

Методы forEach, map, filter, reduce: 

Выведите все элементы массива с помощью forEach. 

Создайте новый массив, умножив каждый элемент исходного массива 

на 2, с помощью map. 

Создайте новый массив, содержащий только четные числа из 

исходного массива, с помощью filter. 

Вычислите сумму всех элементов массива, используя reduce. 

Метод sort: 

Отсортируйте массив чисел по возрастанию и по убыванию 
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Отсортируйте массив строк в алфавитном порядке. 

Практическое задание: 

Создайте массив объектов книг 

Выведите названия книг, у которых количество страниц больше 300 

Создайте массив названий всех книг 

Отсортируйте массив книг по количеству страниц 

Контрольные вопросы: 

Что такое массив и зачем он нужен? 

Как создать массив в JavaScript? 

Какие методы массивов вы знаете и как их использовать? 

В чем разница между forEach, map, filter и reduce? 

Как использовать массивы для обработки коллекций данных? 

 

 

 

 

Фреймворки и библиотеки  
Лабораторная работа №1: Интеграция React в HTML-страницу и 

создание простых компонентов 

Цель работы: 

Получить практические навыки добавления React-компонентов в 

существующую HTML-страницу. 

Научиться создавать и рендерить базовые React-компоненты. 

Познакомиться с основами работы с DOM через React. 

Практическое применение стилизации через Bootstrap. 

Понять принцип разделения контента на компоненты. 

Задания для выполнения: 

Подготовка HTML-страницы: 

Создайте новую HTML-страницу (например, index.html) или откройте 

существующую, если таковая имеется. 

Внутри тега <body> добавьте пустой <div> с уникальным id, где вы 

планируете разместить React-компоненты. Например: 

<!DOCTYPE html> 

<html lang="ru"> 

<head> 

<meta charset="UTF-8"> 

<meta name="viewport" content="width=device-width, initial-scale=1.0"> 

<title>Моя страница с React</title> 

<link rel="stylesheet" 

href="https://stackpath.bootstrapcdn.com/bootstrap/4.5.2/css/bootstrap.min.

css"> 

</head> 

<body> 
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<header class="bg-light py-3"> 

<div class="container"> 

<h1>Мой Блог</h1> 

</div> 

</header> 

<main class="container mt-4"> 

<div id="root"></div> 

</main> 

<footer class="bg-light py-2 mt-4"> 

<div class="container text-center"> 

<p>© 2023 My Blog</p> 

</div> 

</footer> 

 

<!-- Загрузка React --> 

<script src="https://unpkg.com/react@16/umd/react.development.js" 

crossorigin></script> 

<script src="https://unpkg.com/react-dom@16/umd/react-

dom.development.js" crossorigin></script> 

<script src="like_button.js"></script> 

</body> 

</html> 

content_copydownload 

Use code with caution.Html 

Подключение React и Bootstrap: 

Подключение React: Перед закрывающим тегом </body> добавьте три 

тега <script> для подключения библиотек React и React DOM. Обратите 

внимание, что в продакшене нужно 

использовать production.min.js вместо development.js: 

<!-- Загрузка React --> 

<script src="https://unpkg.com/react@16/umd/react.development.js" 

crossorigin></script> 

<script src="https://unpkg.com/react-dom@16/umd/react-

dom.development.js" crossorigin></script> 

 

<!-- Загрузка нашего компонента React --> 

<script src="like_button.js"></script> 

content_copydownload 

Use code with caution.Html 

Подключение Bootstrap: 

Внутри тега <head> добавьте ссылку на CDN-версию Bootstrap CSS: 

<link rel="stylesheet" 

href="https://stackpath.bootstrapcdn.com/bootstrap/4.5.2/css/bootstrap.min.css"> 

content_copydownload 

https://support.google.com/legal/answer/13505487
https://support.google.com/legal/answer/13505487
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Use code with caution.Html 

Создание файла like_button.js и начального кода: 

Создайте файл с именем like_button.js в той же папке, что и ваш index.html. 

Вставьте в него следующий код: 

'use strict'; 

 

const e = React.createElement; 

 

class LikeButton extends React.Component { 

constructor(props) { 

super(props); 

this.state = { liked: false }; 

} 

 

render() { 

if (this.state.liked) { 

return 'Вы поставили лайк.'; 

} 

 

return e( 

'button', 

{ onClick: () => this.setState({ liked: true }) }, 

'Лайк' 

); 

} 

} 

 

 

const domContainer = document.querySelector('#root'); 

ReactDOM.render(e(LikeButton), domContainer); 

content_copydownload 

Use code with caution.JavaScript 

Добавление нескольких кнопок и данных: 

Измените like_button.js, чтобы создать несколько кнопок и передать им 

данные через props: 

'use strict'; 

 

const e = React.createElement; 

 

class LikeButton extends React.Component { 

constructor(props) { 

super(props); 

this.state = { liked: false }; 

} 

https://support.google.com/legal/answer/13505487
https://support.google.com/legal/answer/13505487


92  

 

render() { 

if (this.state.liked) { 

return `Вы поставили лайк посту ${this.props.postId}`; 

} 

 

return e( 

'button', 

{ onClick: () => this.setState({ liked: true }), className: "btn btn-

primary" }, 

`Лайк посту ${this.props.postId}` 

); 

} 

} 

 

class Post extends React.Component { 

render() { 

return e('div', { className: 'card mb-3' }, 

e('div', {className: 'card-body'}, 

e('h5', { className: 'card-title'}, this.props.title), 

e('p', { className: 'card-text'}, this.props.text), 

e(LikeButton, { postId: this.props.id }) 

) 

) 

} 

} 

 

class App extends React.Component { 

render() { 

return e('div', { }, 

e(Post, {id: 1, title: "Заголовок первого поста", text: "Текст 

первого поста"}), 

e(Post, {id: 2, title: "Заголовок второго поста", text: "Текст 

второго поста"}), 

e(Post, {id: 3, title: "Заголовок третьего поста", text: "Текст 

третьего поста"}) 

); 

} 

} 

 

 

 

const domContainer = document.querySelector('#root'); 

ReactDOM.render(e(App), domContainer); 
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content_copydownload 

Use code with caution.JavaScript 

Стилизация и контент (социальная сеть): 

Включен Bootstrap для стилизации кнопок и основного контента. 

Добавлен компонент Post для представления поста. 

Создан компонент App, который рендерит все посты. 

Вывод всего контента с помощью App: 

Все компоненты отрисовываются через App. 

Загрузка на GitHub: 

Создайте репозиторий на GitHub с именем Student. 

Создайте в нем папку по формату Фамилия_1 (латиницей). 

Загрузите туда файлы index.html и like_button.js. 

Методические указания: 

Убедитесь, что HTML-файл содержит правильный id для контейнера, в 

котором React должен рендерить контент. 

Используйте querySelector() для получения 

элемента domContainer в like_button.js. 

Изучите документацию React для более глубокого понимания работы 

компонентов, состояний и props: https://reactjs.org/docs/getting-started.html 

Для более глубокого изучения 

bootstrap: https://getbootstrap.com/docs/4.5/getting-started/introduction/ 

Контрольные вопросы: 

1. С какой целью создавался React? 

2. Что такое компоненты в React? 

3. Чем отличаются props и state? 

4. Как React работает с DOM? 

5. Зачем нужен Bootstrap? 

Дополнительные задачи (повышенный уровень сложности): 

1. Добавьте возможность отображать количество лайков на каждом посте. 

2. Создайте компонент для ввода комментария к посту. 

3. Используйте API для загрузки постов и комментариев. 

4. Изучите использование jsx для более читаемого кода. 

 

 

Лабораторная работа №2: JSX, ключи и метод render в React 

Цель работы: 

Понять, что такое JSX и как он используется для описания UI в React. 

Научиться использовать ключи (keys) для эффективного рендеринга 

списков. 

Углубить понимание метода render в компонентах React. 

Применять полученные знания на практике при создании списков и 

компонентов. 

Задания для выполнения: 

Знакомство с JSX: 

https://support.google.com/legal/answer/13505487
https://www.google.com/url?sa=E&q=https%3A%2F%2Freactjs.org%2Fdocs%2Fgetting-started.html
https://www.google.com/url?sa=E&q=https%3A%2F%2Fgetbootstrap.com%2Fdocs%2F4.5%2Fgetting-started%2Fintroduction%2F
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Начните с существующего файла like_button.js из предыдущей 

лабораторной. 

Замените вызов React.createElement (например e('div', {}, ... )) на 

эквивалентный JSX-синтаксис. 

// Было: 

// return e('div', {className: 'card-body'}, 

//            e('h5', { className: 'card-title'}, this.props.title), 

 

// Стало: 

return ( 

<div className="card-body"> 

<h5 className="card-title">{this.props.title}</h5> 

... 

</div> 

); 

content_copydownload 

Use code with caution.JavaScript 

Перепишите код компонента Post и App, используя JSX-синтаксис. 

Убедитесь, что все работает так же, как и раньше. 

Работа со списками и ключами: 

Создайте компонент PostList, который будет получать массив объектов 

постов в качестве props. 

Используйте метод map для итерации по массиву постов и рендеринга 

каждого поста в виде компонента Post. 

Добавьте атрибут key каждому отрендеренному компоненту Post. Убедитесь, 

что key является уникальным идентификатором для каждого поста 

(например, post.id). 

class PostList extends React.Component { 

render() { 

const posts = this.props.posts.map(post => ( 

<Post key={post.id} id={post.id} title={post.title} text={post.text} 

/> 

)); 

return <div>{posts}</div>; 

} 

} 

content_copydownload 

Use code with caution.JavaScript 

Измените компонент App, чтобы он отображал компонент PostList и 

передавал ему массив постов: 

class App extends React.Component { 

render() { 

const posts = [ 

https://support.google.com/legal/answer/13505487
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{id: 1, title: "Заголовок первого поста", text: "Текст первого 

поста"}, 

{id: 2, title: "Заголовок второго поста", text: "Текст второго 

поста"}, 

{id: 3, title: "Заголовок третьего поста", text: "Текст третьего 

поста"} 

] 

 

return ( 

<div> 

<PostList posts={posts} /> 

</div> 

); 

} 

} 

content_copydownload 

Use code with caution.JavaScript 

Углубленное изучение метода render: 

Добавьте в компонент LikeButton логику для изменения состояния 

компонента, чтобы показать, что рендеринг происходит повторно при 

изменении состояния. 

Добавьте в компонент Post метод shouldComponentUpdate, чтобы 

предотвратить повторный рендеринг, если props не изменились. 

class Post extends React.Component { 

shouldComponentUpdate(nextProps, nextState) { 

if(this.props.title !== nextProps.title || this.props.text !== 

nextProps.text) 

{ 

return true 

} 

return false 

} 

 

render() { 

console.log('render Post ' + this.props.id) 

return ( 

<div className="card mb-3"> 

<div className="card-body"> 

<h5 className="card-title">{this.props.title}</h5> 

<p className="card-text">{this.props.text}</p> 

<LikeButton postId={this.props.id} /> 

</div> 

</div> 

); 
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} 

} 

content_copydownload 

Use code with caution.JavaScript 

Выведите в консоль сообщение перед каждым рендерингом каждого 

компонента LikeButton и Post , чтобы было видно, когда они 

перерендериваются. 

Зафиксируйте в отчете, как ведет себя приложение при изменении 

состояния. 

Стилизация: 

Примените классы Bootstrap для дополнительной стилизации компонентов 

списков. 

Обновление GitHub: 

Загрузите обновленный файл like_button.js в тот же репозиторий, в 

папку Фамилия_1. 

Методические указания: 

Используйте онлайн-конвертеры JSX для понимания, как JSX 

трансформируется в JavaScript (например, https://babeljs.io/repl). 

Особое внимание уделите правильному использованию ключей (key) при 

рендеринге списков. 

Изучите документацию React по методу render и shouldComponentUpdate. 

Поэкспериментируйте с различными вариантами JSX-синтаксиса. 

Контрольные вопросы: 

1. Что такое JSX и зачем он нужен? 

2. Почему использование key важно при рендеринге списков? 

3. Какую роль играет метод render в компоненте React? 

4. В каких случаях может понадобится метод shouldComponentUpdate? 

5. Как можно передавать данные через JSX? 

6. В чем преимущество JSX перед React.createElement? 

Дополнительные задачи (повышенный уровень сложности): 

1. Добавьте возможность редактировать посты. 

2. Реализуйте поиск по списку постов. 

3. Используйте useEffect для отслеживания изменений в данных. 

4. Попробуйте использовать фреймворки для работы с css, например styled 

components. 

 

Лабораторная работа №3: Способы описания компонентов с 

реквизитами (props) и реструктурирование 

Цель работы: 

Углубить понимание передачи данных через props в React. 

Изучить различные способы передачи данных (строки, числа, объекты, 

функции, JSX). 

Научиться использовать деструктуризацию (реструктуризацию) props для 

удобства. 

https://support.google.com/legal/answer/13505487
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Понимать, как и когда использовать defaultProps и propTypes. 

Задания для выполнения: 

 

Ход работы: 

Подготовка среды: 

Убедитесь, что у вас есть рабочая среда React (можно использовать create-

react-app или существующий проект). 

Создайте новый компонент UserCard.js в папке src/components (или 

аналогичной). 

Создание компонента UserCard с разными типами props: 

Откройте файл UserCard.js. 

Начните с создания базовой структуры компонента (функционального 

компонента): 

import React from 'react'; 

 

function UserCard(props) { 

return ( 

<div className="user-card"> 

{/* Здесь будет отображение props */} 

</div> 

); 

} 

 

export default UserCard; 

content_copydownload 

Use code with caution.JavaScript 

Добавьте отображение props внутри div: 

function UserCard(props) { 

return ( 

<div className="user-card"> 

<h2>Имя: {props.name}</h2> 

<p>Возраст: {props.age}</p> 

<p>Активен: {props.isActive ? 'Да' : 'Нет'}</p> 

<div> 

<p>Аватар: <img src={props.profile.avatarUrl} alt="avatar" /></p> 

<p>Биография: {props.profile.bio}</p> 

</div> 

<button onClick={props.onClick}> Нажать </button> 

<div> 

{props.children} 

</div> 

</div> 

); 

} 
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content_copydownload 

Use code with caution.JavaScript 

Обратите внимание, как отображаются строки, числа, булевы значения, 

объекты и JSX. 

Деструктуризация props: 

Измените сигнатуру функции, чтобы использовать деструктуризацию props: 

function UserCard({ name, age, isActive, profile, onClick, children }) { 

// ... 

} 

content_copydownload 

Use code with caution.JavaScript 

Внутри компонента можно использовать name, age, isActive и т.д. напрямую, 

без props.. 

Отредактируйте компонент и убедитесь, что все работает как и раньше. 

defaultProps: 

Добавьте свойства по умолчанию после компонента: 

UserCard.defaultProps = { 

age: 18, 

isActive: false, 

profile: {}, 

}; 

content_copydownload 

Use code with caution.JavaScript 

Теперь, если не передать age, isActive или profile, будут использоваться 

значения по умолчанию. 

Попробуйте удалить эти props из App и убедитесь, что значения 

подставляются по умолчанию. 

propTypes: 

Установите propTypes после defaultProps: 

import PropTypes from 'prop-types'; 

 

UserCard.propTypes = { 

name: PropTypes.string.isRequired, 

age: PropTypes.number, 

isActive: PropTypes.bool, 

profile: PropTypes.shape({ 

avatarUrl: PropTypes.string, 

bio: PropTypes.string, 

}), 

onClick: PropTypes.func, 

children: PropTypes.node, 

}; 

content_copydownload 

Use code with caution.JavaScript 
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Теперь React будет выдавать предупреждения в консоли, если 

переданы props неверного типа или нет props обязательного типа. 

Попробуйте передать age в виде строки, чтобы увидеть предупреждение. 

Примеры использования в App.js: 

Импортируйте компонент UserCard в App.js: 

import UserCard from './components/UserCard'; 

content_copydownload 

Use code with caution.JavaScript 

Используйте компонент несколько раз, передавая различные props: 

function App() { 

return ( 

<div> 

<UserCard 

name="John Doe" 

age={30} 

isActive={true} 

profile={{avatarUrl: "https://via.placeholder.com/150", bio: "Some 

bio"}} 

onClick={() => console.log("clicked")} 

> 

<img src="https://via.placeholder.com/25" alt="icon"/> 

</UserCard> 

<UserCard 

name="Jane Smith" 

profile={{avatarUrl: "https://via.placeholder.com/150", bio: "Some 

other bio"}} 

onClick={() => alert("clicked too!")} 

/> 

<UserCard 

name="Test user" 

onClick={() => alert("clicked three!")} 

/> 

</div> 

); 

} 

content_copydownload 

Use code with caution.JavaScript 

Попробуйте передавать разные типы данных в props, добавлять контент. 

Запустите приложение и убедитесь, что все работает правильно. 

Откройте консоль разработчика и посмотрите, какие предупреждения 

выводятся. 

Отчет: 

Зафиксируйте, как изменяется отображение компонента при 

изменении props. 
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Отметьте, как работает деструктуризация. 

Опишите, как и когда стоит использовать defaultProps и propTypes. 

 

 

Примеры использования 

Создайте компонент App, который будет отображать 

несколько UserCard, передавая в них разные props и контент. 

Покажите пример использования функции в props. 

Методические указания: 

Изучите документацию React по props, defaultProps и propTypes. 

Поэкспериментируйте с различными способами передачи данных. 

Обратите внимание на удобство деструктуризации. 

Используйте propTypes для проверки правильности передачи данных. 

Контрольные вопросы: 

Какие типы данных можно передавать через props? 

Зачем нужна деструктуризация props? 

Как использовать defaultProps? 

Для чего нужны propTypes и как они работают? 

Как передать JSX контент через props? 

Дополнительные задачи: 

Создайте компонент Button, который 

принимает children, onClick и variant (строка). 

Реализуйте кастомную проверку propTypes (например, для проверки email). 

Используйте spread-оператор (...) для передачи части props в дочерний 

компонент. 

 
Лабораторная работа №4: Node.js и условный рендеринг 

Цель работы: 

Понять, что такое условный рендеринг и как его использовать в React. 

Изучить различные способы условного рендеринга (if/else, тернарный 

оператор, логическое &&). 

Познакомиться с основами работы с Node.js и REST API. 

Научиться загружать данные с сервера и отображать их на основе состояния. 

Задания для выполнения: 

Условный рендеринг: 

Создайте компонент Message, который отображает разные сообщения 

в зависимости от значения пропса type (например, "success", "warning", 

"error"). 

Реализуйте это с помощью if/else, тернарного оператора и 

логического && в разных вариантах. 

Покажите пример с использованием switch case. 

Настройте компоненты для каждого типа сообщения. 

Основы Node.js (простой сервер): 
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Создайте простую Node.js-приложение с использованием express и 

JSON-файла. 

Настройте роут для получения списка постов. 

Установите nodemon для автоматического перезапуска сервера. 

Загрузка данных с сервера: 

В компоненте PostList из предыдущей работы добавьте загрузку 

данных о постах с вашего Node.js-сервера с помощью fetch (или axios). 

Используйте useState для хранения загруженных данных и состояния 

загрузки. 

Покажите сообщение о загрузке (например, "Загрузка...") пока данные 

не будут получены. 

Обработайте ошибки, если запрос не удался. 

Используйте useEffect для загрузки данных после первого рендеринга. 

Условный рендеринг на основе состояния: 

Отобразите данные, когда они загрузятся. Если данные не загрузились, 

покажите сообщение об ошибке или loading. 

Покажите в компоненте PostList сообщение "Нет постов", если 

массив posts пустой. 

Методические указания: 

Познакомьтесь с основами Node.js и express. 

Изучите документацию React по условному рендерингу. 

Поэкспериментируйте с разными способами условного рендеринга. 

Убедитесь, что ваш сервер работает правильно, и данные успешно 

загружаются. 

Контрольные вопросы: 

Для чего нужен условный рендеринг? 

Какие есть способы реализации условного рендеринга в React? 

Как обрабатывать ошибки при загрузке данных? 

Зачем нужен useEffect и как его использовать? 

Как создать простой REST API на Node.js? 

Дополнительные задачи: 

Добавьте пагинацию на сервере и на клиенте. 

Реализуйте фильтрацию постов по различным параметрам. 

Используйте библиотеки для работы с fetch (например, axios). 

 
 

 

Лабораторная работа №5: Props, State и события 

Цель работы: 

Углубить понимание props и state и их взаимодействия. 

Научиться обрабатывать события в React (onClick, onChange, onSubmit и др.) 

Управлять состоянием компонента на основе событий. 

Создавать интерактивные компоненты. 

Задания для выполнения: 
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Компонент Counter: 

Создайте компонент Counter с кнопками "+" и "-". 

Используйте useState для хранения текущего значения счетчика. 

Обработайте события клика на кнопки для увеличения и уменьшения 

счетчика. 

Компонент Input: 

Создайте компонент Input с полем ввода и кнопкой "Сохранить". 

Используйте useState для хранения значения поля ввода. 

Обработайте событие onChange в поле ввода для обновления 

состояния. 

Обработайте событие onClick кнопки "Сохранить", чтобы вывести 

введенное значение в консоль. 

Управление state родительского компонента: 

Измените компонент App, чтобы он хранил состояние. 

Создайте компонент ControlPanel, который будет принимать функцию 

для обновления state в App. 

Используйте эту функцию в ControlPanel для изменения состояния 

родительского компонента. 

В App отобразите состояние родителя. 

Формы: 

Создайте форму для добавления новых постов. 

Используйте controlled components. 

Добавьте валидацию форм. 

Методические указания: 

Изучите документацию React по props, state и событиям. 

Поэкспериментируйте с различными типами событий и их обработкой. 

Обратите внимание на разницу между props и state. 

Попробуйте создать более сложные интерактивные компоненты. 

Контрольные вопросы: 

Чем отличаются props и state? 

Как обрабатывать события в React? 

Как управлять state компонента при помощи событий? 

Что такое "controlled components" и для чего они нужны? 

Как передавать функции как props? 

Дополнительные задачи: 

Создайте компонент Modal, который будет отображаться при клике на 

кнопку. 

Реализуйте Drag and Drop для перемещения элементов в списке. 

Создайте компонент-слайдер. 

 
 

 

Лабораторная работа №6: Многостраничные приложения и 

использование массивов в состояниях 
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Цель работы: 

Понять, как создавать многостраничные приложения в React. 

Познакомиться с React Router для навигации между страницами. 

Научиться использовать массивы в state и управлять ими. 

Создавать списки, формы и интерактивные элементы. 

Задания для выполнения: 

Установка и настройка React Router: 

Установите react-router-dom. 

Настройте BrowserRouter в корне приложения. 

Создайте несколько компонентов (например, Home, About, Posts). 

Используйте Route для сопоставления путей с компонентами. 

Добавьте Link для навигации между страницами. 

Массивы в state: 

В компоненте Posts храните список постов в state (используя массив 

объектов). 

Отобразите посты на странице. 

Реализуйте возможность добавлять, удалять и редактировать посты с 

использованием state массива. 

Используйте map для отображения массива. 

Формы: 

Создайте форму для добавления новых постов. 

Используйте controlled components. 

Добавьте валидацию форм. 

Работа с ключами (key) в списках: 

Убедитесь, что при добавлении, удалении или редактировании постов, React 

правильно отслеживает изменения. 

Методические указания: 

Изучите документацию по React Router. 

Поймите, как работают массивы в state и как их правильно обновлять. 

Изучите разницу между нативным array методами и тем, что возращает map 

Обратите внимание на то, что нужно использовать key в списках. 

Контрольные вопросы: 

Как работает React Router и для чего он нужен? 

Как настроить роутинг в React-приложении? 

Как использовать массивы в state и их обновлять? 

Для чего нужны ключи (key) в списках? 

Как использовать формы в React? 

Дополнительные задачи: 

Добавьте аутентификацию для доступа к страницам. 

Используйте параметры в пути. 

Реализуйте поиск постов. 

Добавьте модальные окна. 
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ТЕСТОВЫЕ ЗАДАНИЯ 

 

Тема 1.1 Проектирование и дизайн интерфейсов 

Профессиональная(-ые) компетенция(-ии): 

ПК.8.1 Разрабатывать дизайн-концепции веб-приложений в соответствии с 

корпоративным стилем заказчика 

Задание №1 

Выполните тестовые задания "Графический редактор Adobe Photoshop" 

 
1. Какой инструмент "переносит" цвет пиксела из изображения на 

цветовые поля палитры инструментов? 

a) штамп; 

b) кисть; 

c) прямоугольник; 

d) пипетка. 

2. Что такое кадрирование изображения? 

a) изменение контрастности изображения; 

b) отсечение частей изображения с целью фокусирования или 

улучшения компоновки; 

c) улучшение качества изображения; 

d) изменение цветовой гаммы. 

3. Инструмент, позволяющий плавно переходить от одного цвета к другому 

– это… 

a) губка; 

b) штамп; 

c) кисть; 

d) градиент. 

4. Какой из заголовков верхнего меню нужно выбрать, чтобы 

изменить размеры холста? 

a) файл; 

b) редактирование; 

c) изображение; 

d) слой. 

5. Какого инструмента нет в фотошопе? 

a) лассо; 

b) круглое лассо; 

c) многоугольное лассо; 

d) магнитное лассо. 

6. Какой из этих режимов НЕ является настройками ластика? 

a) обычный; 

b) кисть; 

c) карандаш; 

d) блок. 
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7. Какой режим выделения необходимо включить, чтобы выделить 

лампочки, как показано на рисунке? 

 

 
a) 

 

 

 
b) 

 

 

 
c) 

 

 

 

d) 

 

 

 
8. При работе с операцией Трансформирование, чтобы отменить эту 

операцию необходимо нажать 

a) 

 
 

b) 

 
 

9. Гистограмма — это … 

a) диаграмма специального вида, который показывает 

распределение цвета от белого к черному; 

b) график специального вида, который показывает распределение 

пикселов по яркости, от белого к черному. 

10. Особенность цветовой коррекции заключается в … 

a) изменение одного цвета влечет за собой изменение других цветов 

изображения; 
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b) настройки баланса цветов; 

c) изменении конкретного цвета. 
 
 

Оценк

а 

Показатели оценки 

3 Выполнены 3-6 заданий. 

4 Выполнены 7-8 заданий. 

5 Выполнены 9-10 заданий. 

 
Задание №2 (из текущего контроля) 

Ответить на вопросы: 

Сопоставьте цветовые сочетания и экспрессивные или дисгармоничные цвета, 

получающиеся при их смешении. 

Как выглядит формула Гете активности цвета в зависимости от его яркости? Как 

изменяется цветовая гармония в зависимости от изменения насыщенности и 

светлоты исходных цветов? 

 

Оценк

а 

Показатели оценки 

3 Дан ответ на один вопрос . 

4 Даны ответы на 2 вопроса из 3. 

5 Даны ответы на все 3 вопроса. 

 
Дидактическая единица для контроля: 

 современные тенденции дизайна 
Профессиональная(-ые) компетенция(-ии): 

ПК.8.1 Разрабатывать дизайн-концепции веб-приложений в соответствии с 

корпоративным стилем заказчика 

Задание №1 

Ответить на вопросы: 

1. Аппаратные средства мультимедиа технологии. 

2. Программные средства мультимедиа технологии. 

3. Классификация мультимедиа-технологий. 
 
 

Оценк

а 

Показатели оценки 

3 Дан ответ на 1 вопрос из 3. 

4 Дан ответ на 2 вопроса из 3. 

5 Даны ответы на все вопросы. 

 

Задание №2 (из текущего контроля) 

Привидите пример не менее 8 современных трендов web дизайна. 
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Оценк

а 

Показатели оценки 

3 Привиден пример 4 трендов. 

4 Приведен пример 6 трендов. 

5 Приведен пример 8 трендов. 

 
Дидактическая единица для контроля: 

 инструменты для разработки эскизов, схем интерфейсов и 

прототипа дизайна веб-приложений 

Профессиональная(-ые) компетенция(-ии): 

ПК.8.1 Разрабатывать дизайн-концепции веб-приложений в соответствии с 

корпоративным стилем заказчика 

Задание №1 

Установите соответствие между видами компьютерной графики (КГ) и их 

назначением. 

 

 
 

 

 

 
 

Оценк

а 

Показатели оценки 

3 Установлено 3 - 4 соответствия. 

4 Установлено 5-6 соответствий. 

5 Установлены все соответствия 

 

Задание №2 (из текущего контроля) 

Ответить на вопросы теста: 

1. Использование цвета для оформления текста… 
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a) только стандартные 16 цветов; 

б) 48 цветов палитры 

редактора; в) любые; 

г) только черный. 

2. Использоваться на странице могут дополнительные элементы 

оформления: 
a

) 

з

в

у

к

и

; 

б

) 

в

и

д

е

о

; 

в) бегущие строки; 

г) все вышеперечисленные. 

3. Изображения, вставляемые на страницу: 
a) переводятся в двоичную форму и помещаются в HTML-

код; б) записываются в архив и прилагаются к HTML-файлу; 

в) изображения не сохраняются, а при просмотре используются из библиотеки 

пользователя; 

г) сохраняются как отдельные файлы, а в HTML-код вставляется только ссылка на 

них. 

4. Графика, представляемая в памяти компьютера в виде 

совокупности точек, называется: 
a) 

растро

вой; б) 

вектор

ной; в) 

трехме

рной; 

г) 

фракта

льной. 

5. Элементарным объектом растровой графики является следующий: 
a) рисуется одним 

инструментом; б) пиксель; 

в) символ; 

г) примитив. 

6. Инструмент, позволяющий залить изображение двумя, плавно 
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перетекающими друг в друга цветами, называется: 
a) банка 

краски; 

б) 

заливка

; 

в) 

гра

ди

ент

; г) 

узо

р. 

 

Оценк

а 

Показатели оценки 

3 Даны ответы на 4 из 6 вопросов правильно. 

4 Даны ответы на 5 из 6 вопросов правильно. 

5 Даны ответы на все вопросы правильно. 

 
Раздел 2 Верстка страниц 

 
Тест по верстке сайта (1 вариант) 

Инструкция: Выберите один правильный ответ из предложенных 

вариантов. 

1. Какой тег используется для создания заголовка первого уровня в 

HTML? 

o a) <heading> 

o b) <h1/> 

o c) <title> 

o d) <header> 

2. Какой тег используется для создания абзаца? 

o a) <text> 

o b) <paragraph> 

o c) <p> 

o d) <par> 

3. Какой тег используется для создания ссылки? 

o a) <link> 

o b) <href> 

o c) <url> 

o d) <a> 

4. Какой тег используется для вставки изображения? 

o a) <image> 

o b) <src> 

o c) <img> 

o d) <picture> 
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5. Какой атрибут используется для указания адреса ссылки? 

o a) src 

o b) url 

o c) href 

o d) link 

6. Какой тег используется для создания нумерованного списка? 

o a) <ul> 

o b) <list> 

o c) <ol> 

o d) <li> 

7. Какой тег используется для создания ненумерованного списка? 

o a) <ol> 

o b) <ul> 

o c) <list> 

o d) <li> 

8. Какой тег используется для создания элемента списка? 

o a) <list> 

o b) <ul> 

o c) <ol> 

o d) <li> 

9. Какой атрибут используется для указания пути к изображению? 

o a) href 

o b) url 

o c) src 

o d) link 

10. Какой тег используется для создания таблицы? 

o a) <table_box> 

o b) <table> 

o c) <table> 

o d) <grid> 

11. Какой тег используется для создания строки в таблице? 

o a) <td> 

o b) <tr> 

o c) <th> 

o d) <row> 

12. Какой тег используется для создания ячейки в таблице? 

o a) <tr> 

o b) <th> 

o c) <td> 

o d) <cell> 

13. Какой тег используется для создания заголовка столбца в таблице? 

o a) <td> 

o b) <th> 

o c) <tr> 

o d) <header_cell> 

14. Что такое CSS? 
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o a) Язык программирования 

o b) Язык разметки 

o c) Язык стилей 

o d) База данных 

15. Как добавить CSS-стили в HTML-документ? 

o a) Через атрибут style 

o b) Через тег <style> 

o c) Через внешний файл 

o d) Все вышеперечисленные варианты 

16. Как выбрать элемент с классом "my-class" в CSS? 

o a) #my-class 

o b) .my-class 

o c) my-class 

o d) class-my-class 

17. Как выбрать элемент с id "my-id" в CSS? 

o a) .my-id 

o b) my-id 

o c) #my-id 

o d) id-my-id 

18. Какое свойство CSS используется для изменения цвета текста? 

o a) background-color 

o b) color 

o c) text-color 

o d) font-color 

19. Какое свойство CSS используется для изменения размера шрифта? 

o a) font-size 

o b) text-size 

o c) font-height 

o d) size 

20. Какое свойство CSS используется для задания отступов вокруг 

элемента? 

o a) padding 

o b) margin 

o c) border 

o d) spacing 

21. Какое свойство CSS используется для задания внешних отступов вокруг 

элемента? 

o a) padding 

o b) margin 

o c) border 

o d) spacing 

22. Какое свойство CSS используется для задания границ элемента? 

o a) padding 

o b) margin 

o c) border 

o d) outline 
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23. Что такое адаптивная верстка? 

o a) Верстка для больших экранов 

o b) Верстка для маленьких экранов 

o c) Верстка, которая адаптируется под разные размеры экранов 

o d) Верстка только для мобильных устройств 

24. Какой CSS-метод используется для создания адаптивного макета? 

o a) flexbox 

o b) grid 

o c) float 

o d) Все вышеперечисленные варианты 

25. Что такое медиа-запросы в CSS? 

o a) Запросы для работы с сервером 

o b) Запросы к базе данных 

o c) Условия для применения стилей в зависимости от 

характеристик устройства 

o d) Запросы для работы с API 

26. Какое свойство CSS используется для создания сетки? 

o a) flex-grid 

o b) layout 

o c) grid 

o d) template 

27. Какое свойство CSS используется для задания ширины элемента? 

o a) size 

o b) width 

o c) height 

o d) size-width 

28. Какое свойство CSS используется для задания высоты элемента? 

o a) size 

o b) width 

o c) height 

o d) size-height 

29. Какой псевдокласс используется для добавления стиля при наведении 

курсора на элемент? 

o a) :hover 

o b) :focus 

o c) :active 

o d) :visited 

30. Какой HTML-тег используется для добавления метаданных к 

документу? 

o a) <meta> 

o b) <head> 

o c) <header> 

o d) <information> 

 

 

Ключи ответов: 

1. b 
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2. c 

3. d 

4. c 

5. c 

6. c 

7. b 

8. d 

9. c 

10. b 

11. b 

12. c 

13. b 

14. c 

15. d 

16. b 

17. c 

18. b 

19. a 

20. a 

21. b 

22. c 

23. c 

24. d 

25. c 

26. c 

27. b 

28. c 

29. a 

30. a 

 

Раздел 3 Разработка клиентской части информационных 

ресурсов 

Тест по JavaScript (2 варианта) 

Инструкция: Выберите один правильный ответ из предложенных 

вариантов. 

Вариант 1 

1. Какой оператор используется для сравнения двух значений на строгое 

равенство (с учетом типа данных)? 

o a) = 

o b) == 

o c) === 

o d) != 

2. Какой тип данных в JavaScript используется для представления 

логических значений (истина или ложь)? 

o a) number 

o b) string 
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o c) boolean 

o d) null 

3. Какой цикл используется для выполнения блока кода определенное 

количество раз? 

o a) while 

o b) do...while 

o c) for 

o d) if 

4. Какое ключевое слово используется для объявления переменной, 

значение которой нельзя будет изменить после присваивания? 

o a) var 

o b) let 

o c) const 

o d) new 

5. Что выведет в консоль следующий код: console.log(typeof null);? 

o a) "null" 

o b) "object" 

o c) "undefined" 

o d) "number" 

6. Как вызвать функцию myFunction? 

o a) call myFunction 

o b) run myFunction 

o c) myFunction() 

o d) new myFunction 

7. Что такое рекурсивная функция? 

o a) Функция, которая выполняется один раз 

o b) Функция, которая вызывает сама себя 

o c) Функция, которая никогда не заканчивает выполнение 

o d) Функция которая возвращает массив 

8. Как добавить новый элемент в конец массива myArray? 

o a) myArray.add(element) 

o b) myArray.insert(element) 

o c) myArray.push(element) 

o d) myArray[element] 

9. Какой метод массива используется для создания нового массива, 

который состоит только из элементов, удовлетворяющих условию? 

o a) map 

o b) forEach 

o c) filter 

o d) reduce 

10. Как получить доступ к свойству name объекта user? 

o a) user(name) 

o b) user[name] 

o c) user.name 

o d) user->name 

11. Что делает метод join() массива? 

o a) Складывает элементы массива 
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o b) Разворачивает массив 

o c) Преобразует массив в строку 

o d) Сортирует массив 

12. Что выведет этот код console.log(2 + '2')? 

o a) 4 

o b) "4" 

o c) "22" 

o d) Error 

13. Что делает splice метод? 

o a) Возвращает часть массива 

o b) Добавляет, удаляет и заменяет элементы массива 

o c) Копирует массив 

o d) Сортирует массив 

14. Какой метод массива используется для перебора элементов? 

o a) sort 

o b) push 

o c) map 

o d) forEach 

15. Какое ключевое слово указывает на текущий объект в методах объекта? 

o a) this 

o b) that 

o c) it 

o d) self 

Вариант 2 

1. Какой оператор используется для присваивания значения переменной? 

o a) == 

o b) === 

o c) = 

o d) != 

2. Какой тип данных в JavaScript используется для представления 

текстовых значений? 

o a) number 

o b) string 

o c) boolean 

o d) null 

3. Какой цикл выполняется хотя бы один раз, даже если условие ложно? 

o a) while 

o b) do...while 

o c) for 

o d) if 

4. Какое ключевое слово используется для объявления переменной, 

значение которой может быть изменено? 

o a) const 

o b) let 

o c) new 

o d) var 
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5. Что выведет в консоль следующий код: console.log(typeof undefined);? 

o a) "null" 

o b) "object" 

o c) "undefined" 

o d) "number" 

6. Как передать аргумент value в функцию myFunction при вызове? 

o a) myFunction(value) 

o b) myFunction = value 

o c) myFunction as value 

o d) value myFunction 

7. Что такое колбэк функция? 

o a) Функция, которую возвращает другая функция 

o b) Функция которая вызывает сама себя 

o c) Функция, которая передается в качестве аргумента другой 

функции 

o d) Функция которая возвращает объект 

8. Какой метод массива используется для удаления последнего элемента? 

o a) myArray.delete() 

o b) myArray.pop() 

o c) myArray.remove() 

o d) myArray.splice() 

9. Какой метод массива используется для преобразования каждого 

элемента массива и создания нового массива? 

o a) map 

o b) forEach 

o c) filter 

o d) reduce 

10. Как получить значение свойства email у объекта user через []? 

o a) user.email 

o b) user["email"] 

o c) user(email) 

o d) user->email 

11. Что делает метод concat() массива? 

o a) Объединяет массивы 

o b) Разделяет массив 

o c) Удаляет элементы массива 

o d) Сортирует массив 

12. Что выведет этот код console.log(2 * '2')? 

o a) 4 

o b) "4" 

o c) "22" 

o d) Error 

13. Что делает slice метод? 

o a) Добавляет элемент массива 

o b) Удаляет элементы массива 

o c) Возвращает часть массива 
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o d) Изменяет размер массива 

14. Какой метод массива позволяет сложить все элементы массива и 

получить 1 значение? 

o a) map 

o b) forEach 

o c) filter 

o d) reduce 

15. Как вывести значение свойства age в методе объекта user? 

o a) this.age 

o b) user.age 

o c) age 

o d) user->age 

Ключи ответов 

Вариант 1 

1. c 

2. c 

3. c 

4. c 

5. b 

6. c 

7. b 

8. c 

9. c 

10. c 

11. c 

12. c 

13. b 

14. d 

15. a 

Вариант 2 

1. c 

2. b 

3. b 

4. b 

5. c 

6. a 

7. c 

8. b 

9. a 

10. b 

11. a 

12. a 

13. c 

14. d 

15. a 
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Тест по React (2 варианта) 

Инструкция: Выберите один правильный ответ из предложенных 

вариантов. 

Вариант 1 

1. Какой метод используется для рендеринга React-компонента в DOM? 

o a) ReactDOM.mount() 

o b) ReactDOM.render() 

o c) ReactDOM.update() 

o d) ReactDOM.display() 

2. Что такое JSX? 

o a) JavaScript-расширение для написания стилей 

o b) JavaScript-расширение для описания UI 

o c) JavaScript-библиотека для работы с DOM 

o d) JavaScript-библиотека для работы с API 

3. Что такое props в React? 

o a) Внутреннее состояние компонента 

o b) Данные, передаваемые в компонент от родителя 

o c) Метод компонента 

o d) Событие компонента 

4. Какой хук используется для работы с состоянием компонента в 

функциональных компонентах? 

o a) useState() 

o b) useEffect() 

o c) useRef() 

o d) useContext() 

5. Как передать данные из родительского компонента в дочерний? 

o a) Через state 

o b) Через props 

o c) Через refs 

o d) Через context 

6. Какой метод используется для получения доступа к DOM-элементу 

через React? 

o a) getElement() 

o b) findNode() 

o c) useRef() 

o d) querySelector() 

7. Что такое условный рендеринг в React? 

o a) Метод стилизации элементов 

o b) Метод обработки данных в форме 

o c) Отображение элементов в зависимости от условий 

o d) Метод работы с API 

8. Какой метод используется для загрузки данных с сервера в React? 

o a) send() 

o b) ajax() 

o c) fetch() 

o d) import() 

9. Для чего нужен key при рендеринге списков в React? 
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o a) Для стилизации элементов 

o b) Для определения уникальности элемента 

o c) Для добавления анимации 

o d) Для добавления обработчиков событий 

10. Какой метод React используется для предотвращения повторного 

рендеринга компонента, если его props не изменились? 

o a) componentDidUpdate() 

o b) shouldComponentUpdate() 

o c) componentWillUpdate() 

o d) render() 

11. В каком порядке выполняются хуки в компоненте React? 

o a) useEffect, useState, useRef 

o b) useState, useEffect, useRef 

o c) useRef, useState, useEffect 

o d) Порядок не важен 

12. Как отобразить контент внутри React-компонента? 

o a) С помощью HTML 

o b) Через document.body 

o c) С помощью render() 

o d) С помощью CSS 

13. Какой тег используется для контейнера, в который будет рендериться 

React? 

o a) <body> 

o b) <app> 

o c) <div> 

o d) <span> 

14. Что такое компонент в React? 

o a) Функция для отрисовки html 

o b) Функция, для получения данных с сервера 

o c) Функция или класс, которые описывают интерфейс 

o d) Функция для работы с css 

15. Какой пакет используется для навигации между страницами в React? 

o a) react-navigation 

o b) react-routing 

o c) react-router-dom 

o d) react-pages 

16. Какой метод используется для обработки события клика в React? 

o a) click() 

o b) onClick() 

o c) onMouseClick() 

o d) handleClick() 

17. Зачем нужен defaultProps в компоненте React? 

o a) Для передачи обязательных пропсов 

o b) Для задания значений по умолчанию для пропсов 

o c) Для стилизации 

o d) Для валидации пропсов 
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18. Какой хук используется для выполнения побочных эффектов (загрузка 

данных, подписки)? 

o a) useState() 

o b) useRef() 

o c) useEffect() 

o d) useContext() 

19. Что выведет в консоль следующий код? 

20. function MyComponent({prop}) { 

21.        return ( 

22.           <h1>{prop}</h1> 

23.      ); 

24.   } 

25.     MyComponent.defaultProps = { 

26.         prop: 'hello' 

27.     } 

 ReactDOM.render(<MyComponent />, document.getElementById('root')); 

content_copydownload 

Use code with caution.JavaScript 

o a) undefined 

o b) null 

o c) hello 

o d) Пустая строка 

28. Как добавить стили bootstrap к React-компоненту? 

o a) Через style 

o b) Через css 

o c) Через классы 

o d) Невозможно 

Вариант 2 

1. Какой метод используется для обновления React-компонента в DOM? 

o a) ReactDOM.mount() 

o b) ReactDOM.render() 

o c) ReactDOM.update() 

o d) ReactDOM.display() 

2. Что такое state в React? 

o a) Данные, передаваемые от родителя 

o b) Внутреннее состояние компонента 

o c) Метод компонента 

o d) Событие компонента 

3. Какой хук используется для работы с побочными эффектами в 

функциональных компонентах? 

o a) useState() 

o b) useEffect() 

o c) useRef() 

o d) useContext() 

4. Как обновить состояние компонента в React? 

o a) this.setState() 

https://support.google.com/legal/answer/13505487
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o b) this.updateState() 

o c) setMyState() 

o d) state = new value 

5. Что такое controlled component? 

o a) Компонент, который не управляет своим состоянием 

o b) Компонент, состояние которого управляется родителем 

o c) Компонент, который никогда не перерендеривается 

o d) Компонент только для отображения данных 

6. Как правильно использовать key при map? 

o a) Как index массива 

o b) Как название элемента 

o c) Как уникальный id 

o d) Как строку 

7. В каких случаях необходимо использовать условный рендеринг? 

o a) Для получения данных с сервера 

o b) Для добавления анимаций 

o c) Для отображения разных UI в зависимости от состояния 

o d) Для стилизации элементов 

8. Какой метод используется для отслеживания изменений состояния в 

React? 

o a) stateChange 

o b) onStateChange 

o c) useEffect 

o d) stateUpdate 

9. Почему важно деструктурировать props? 

o a) Для стилизации компонента 

o b) Для краткости кода 

o c) Для обеспечения безопасности 

o d) Для того, чтобы избежать ошибок 

10. Какой метод React используется для добавления обработчика события 

на DOM-элемент? 

o a) addListener 

o b) addEventListener 

o c) onEvent 

o d) on 

11. Для чего нужны ключи в компонентах React? 

o a) Для стилизации компонента 

o b) Для того, чтобы избежать ошибок 

o c) Для оптимизации рендеринга 

o d) Для привязки к конкретному dom-элементу 

12. Как использовать JSX-код внутри React компонента? 

o a) В виде css-классов 

o b) В виде обычного html 

o c) В виде строк 

o d) В виде возвращаемого значения функции 

13. Где обычно размещают id контейнера для React-приложения? 
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o a) <head> 

o b) <header> 

o c) <body> 

o d) <footer> 

14. Какое из этих утверждений не верно? 

o a) Компонент может принимать props 

o b) Компонент может содержать состояние 

o c) Компонент может принимать другое компоненты 

o d) Компонент может менять props родителя 

15. Какой хук используется для получения ref? 

o a) useState() 

o b) useEffect() 

o c) useRef() 

o d) useCallback() 

16. Какой метод нужно использовать для отображения массива в JSX? 

o a) for 

o b) while 

o c) map 

o d) forEach 

17. Что делает propTypes в React? 

o a) Передает данные 

o b) Задает стили 

o c) Проверяет тип данных пропсов 

o d) Задает значения по умолчанию 

18. Что такое побочный эффект в React? 

o a) Любое действие, не связанное с отрисовкой UI 

o b) Функция, которая возвращает массив 

o c) Код, который изменяет состояние 

o d) Функция которая вызывает другую функцию 

19. Что выведет в консоль следующий код? 

20. function MyComponent({prop}) { 

21.      return ( 

22.         <h1>{prop}</h1> 

23.       ); 

24. } 

ReactDOM.render(<MyComponent prop="hello"/>, 

document.getElementById('root')); 

content_copydownload 

Use code with caution.JavaScript 

o a) undefined 

o b) null 

o c) hello 

o d) Пустая строка 

25. Как можно использовать bootstrap классы в React? 

o a) В виде строк 

o b) Через style 

https://support.google.com/legal/answer/13505487


12
4 

 

o c) Через className 

o d) Через id 

Ключи ответов 

Вариант 1 

1. b 

2. b 

3. b 

4. a 

5. b 

6. c 

7. c 

8. c 

9. b 

10. b 

11. b 

12. c 

13. c 

14. c 

15. c 

16. b 

17. b 

18. c 

19. c 

20. c 

Вариант 2 

1. b 

2. b 

3. b 

4. a 

5. b 

6. c 

7. c 

8. c 

9. b 

10. b 

11. c 

12. d 

13. c 

14. d 

15. c 

16. c 

17. c 

18. a 

19. c 

20. c 
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ЭКЗАМЕНАЦИОННЫЕ БИЛЕТЫ 

 

Экзаменационные билеты по дисциплине «МДК 04.01 Проектирование и дизайн 

интерфейсов» 

Инструкция: Каждый билет содержит два теоретических вопроса и одно практическое 

задание. Ответьте на вопросы и выполните практическое задание. 

 

Билет № 1 

Вопрос 1: Что такое растровые и векторные изображения и в каких случаях лучше 

использовать каждый из них? 

Вопрос 2: Назовите основные инструменты Photoshop для работы с выделениями. 

Практическое задание: Создайте в Photoshop коллаж из нескольких фотографий, 

используя инструменты выделения, слои и маски. 

 

Билет № 2 

Вопрос 1: Что такое слои в Photoshop и зачем они нужны? 

Вопрос 2: Как создать и использовать стили слоев (layer styles) в Photoshop? 

Практическое задание: В Photoshop создайте кнопку с градиентом, тенью и обводкой, 

используя стили слоя. 

 

Билет № 3 

Вопрос 1: Что такое маски в Photoshop и какие их виды вы знаете? 

Вопрос 2: Как использовать инструменты для ретуширования изображений в Photoshop 

(healing brush, clone stamp)? 

Практическое задание: Ретушируйте в Photoshop портретную фотографию, удалив мелкие 

дефекты и неровности кожи. 

 

Билет № 4 

Вопрос 1: Что такое цветовые модели RGB и CMYK и в каких случаях они 

используются? 

Вопрос 2: Как создать и использовать смарт-объекты в Photoshop? 

Практическое задание: В Photoshop создайте несколько вариантов баннера, используя 

смарт-объекты для текста и логотипа. 

 

Билет № 5 

Вопрос 1: Что такое гайдлайны и зачем они нужны при работе с UI/UX дизайном? 

Вопрос 2: Что такое компоненты в Figma и как они помогают ускорить процесс 

проектирования? 

Практическое задание: Создайте в Figma библиотеку компонентов для базовых элементов 

веб-интерфейса (кнопки, поля ввода, иконки). 

 

Билет № 6 

Вопрос 1: Что такое фреймы (frames) в Figma и чем они отличаются от групп (groups)? 

Вопрос 2: Как использовать автолейаут (auto layout) в Figma для создания адаптивных 

элементов? 

Практическое задание: В Figma создайте навигационную панель с автолейаутом, которая 
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автоматически изменяет размеры элементов при изменении размера экрана. 

 

Билет № 7 

Вопрос 1: Какие виды шрифтов вы знаете и какие особенности их использования в веб-

дизайне? 

Вопрос 2: Что такое плагины в Figma и как их устанавливать и использовать? 

Практическое задание: В Figma разработайте макет простого лендинга с использованием 

плагинов для работы с текстом, изображениями и иконками. 

 

Билет № 8 

Вопрос 1: Что такое UI kit и для чего он нужен? 

Вопрос 2: Как использовать прототипирование в Figma для создания интерактивных 

макетов? 

Практическое задание: В Figma создайте прототип мобильного приложения с 

несколькими экранами и интерактивными переходами. 

 

Билет № 9 

Вопрос 1: Что такое пользовательский опыт (UX) и пользовательский интерфейс (UI)? 

Вопрос 2: Как использовать стили (styles) в Figma для унификации элементов? 

Практическое задание: В Figma создайте макет страницы сайта, используя общие стили 

для текста, цветов и элементов. 

 

Билет № 10 

Вопрос 1: Что такое сетка (grid) в дизайне и как ее использовать для создания 

гармоничного макета? 

Вопрос 2: Как экспортировать элементы из Photoshop или Figma в разных форматах? 

Практическое задание: Создайте в Photoshop или Figma макет страницы с элементами, 

расположенными в соответствии с модульной сеткой. 

 

Билет № 11 

Вопрос 1: Что такое композиция в дизайне и как она влияет на восприятие интерфейса? 

Вопрос 2: Как создавать и использовать маски слоя в Figma? 

Практическое задание: В Figma создайте макет карточки продукта с использованием 

масок слоя для создания эффекта глубины и размытия фона. 

 

Билет № 12 

Вопрос 1: Что такое иконографика и какие основные правила ее создания? 

Вопрос 2: Как использовать варианты (variants) компонентов в Figma для создания 

гибких элементов? 

Практическое задание: В Figma разработайте набор иконок для веб-приложения, 

используя варианты компонентов для разных состояний (активно, неактивно, наведение). 

 

Билет № 13 

Вопрос 1: Что такое типографика и как подбирать шрифты для UI-дизайна? 

Вопрос 2: Какие принципы доступности (accessibility) следует учитывать при 

проектировании интерфейса? 

Практическое задание: В Figma создайте макет веб-страницы, где используются 
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различные шрифты для заголовков и текста. Примените контрастные цвета для 

обеспечения читаемости. 

 

Билет № 14 

Вопрос 1: Как выбрать цветовую палитру для веб-интерфейса? 

Вопрос 2: Как использовать эффекты (shadows, blurs) в Figma для создания 

реалистичного вида? 

Практическое задание: В Figma создайте несколько вариантов карточки товара с разными 

вариантами цветовой палитры и добавьте эффекты для придания объема. 

 

Билет № 15 

Вопрос 1: Что такое wireframe и для чего он нужен? 

Вопрос 2: Как использовать constraints в Figma для адаптивного дизайна? 

Практическое задание: В Figma создайте wireframe для мобильного приложения с 

базовыми элементами, используя constraints для адаптивности. 

 

Билет № 16 

Вопрос 1: Что такое мокап и для чего он нужен? 

Вопрос 2: Как использовать component sets в Figma? 

Практическое задание: Создайте мокап для мобильного приложения, используя 

компонент sets. 

 

Билет № 17 

Вопрос 1: Какие есть способы создания UI анимаций? 

Вопрос 2: Как работать с auto layout? 

Практическое задание: Создайте анимацию переключения между страницами, используя 

smart animate в Figma. 

 

Билет № 18 

Вопрос 1: Какие есть правила создания UI элементов? 

Вопрос 2: Что такое accessibility в дизайне? 

Практическое задание: Разработайте дизайн формы с акцентом на accessibility. 

 

Билет № 19 

Вопрос 1: В чем разница между vector и raster изображениями? 

Вопрос 2: Какие есть способы задания цвета в Figma? 

Практическое задание: Сделайте редизайн существующего сайта, с акцентом на цветовую 

палитру. 

 

Билет № 20 

Вопрос 1: Как использовать стили для унификации дизайна? 

Вопрос 2: Что такое micro interactions? 

Практическое задание: Разработайте форму с микро анимациями, с использованием 

плагинов в Figma. 

 

Билет № 21 

Вопрос 1: Как выбрать шрифт для сайта? 
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Вопрос 2: Что такое UI patterns? 

Практическое задание: Разработайте несколько вариантов дизайна одной и той же 

страницы, используя разные UI patterns. 

 

Билет № 22 

Вопрос 1: Что такое UX research? 

Вопрос 2: Что такое atomic design? 

Практическое задание: Разработайте дизайн сайта используя atomic design. 

 

Билет № 23 

Вопрос 1: Что такое responsive design? 

Вопрос 2: Как работать с constraints? 

Практическое задание: Разработайте дизайн для нескольких размеров экрана. 

 

Билет № 24 

Вопрос 1: Как создавать UI анимации? 

Вопрос 2: Какие инструменты в Figma вы знаете? 

Практическое задание: Создайте анимацию и выгрузите ее в mp4. 

 

Билет № 25 

Вопрос 1: Какие есть правила верстки для UI дизайна? 

Вопрос 2: Как работать со слоями в Figma? 

Практическое задание: Создайте экран с несколькими сложными UI элементами, 

используя Figma. 

 

 

 

Экзаменационные билеты по дисциплине  « МДК 04.02 Верстка страниц» 

Инструкция: Каждый билет содержит два теоретических вопроса и одно практическое 

задание. Ответьте на вопросы и выполните практическое задание. 

 

Билет № 1 

Вопрос 1: Что такое HTML и какова его основная роль в веб-разработке? 

Вопрос 2: Какие существуют основные способы подключения CSS к HTML-документу? 

Практическое задание: Создайте HTML-структуру для главной страницы простого 

блога. Включите заголовок (h1) с названием блога, панель навигации (nav) с тремя 

ссылками, блок с несколькими статьями (article), где у каждой статьи есть заголовок (h2) 

и краткое описание (p), и подвал (footer). 

 

Билет № 2 

Вопрос 1: Опишите разницу между тегами <div> и <span> в HTML. 

Вопрос 2: Как задать цвет текста с помощью CSS? Приведите пример. 

Практическое задание: Создайте HTML-список (ненумерованный ul или 

нумерованный ol) и добавьте к нему CSS-стили. Список должен иметь разный цвет 

маркеров или нумерации, разный шрифт и цвет текста для четных и нечетных элементов 

списка. 
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Билет № 3 

Вопрос 1: Какие типы списков существуют в HTML и чем они отличаются? 

Вопрос 2: Что такое селекторы в CSS и какие основные типы селекторов вы знаете? 

Практическое задание: Создайте HTML-таблицу, представляющую расписание занятий. 

Таблица должна иметь заголовок, не менее 4 строк и 5 столбцов. Добавьте стили для 

ячеек заголовка (th), а также чередующийся фон для строк таблицы. 

 

Билет № 4 

Вопрос 1: Что такое атрибуты в HTML и приведите пример их использования. 

Вопрос 2: Как изменить размер шрифта с помощью CSS? Приведите пример. 

Практическое задание: Создайте HTML-форму для регистрации пользователя. Форма 

должна включать поля для ввода имени, email, пароля (маскированного), выбора пола 

(radio) и флажок (checkbox) для согласия с условиями. Добавьте кнопку 

"Зарегистрироваться". 

 

Билет № 5 

Вопрос 1: Какие существуют типы ссылок в HTML и как они работают? 

Вопрос 2: Как задать отступы вокруг элемента с помощью CSS? Приведите пример. 

Практическое задание: Создайте блок, содержащий три изображения (img) в ряд. 

Каждое изображение должно иметь свою ширину, заданную в процентах. Добавьте 

отступы между изображениями. 

 

Билет № 6 

Вопрос 1: Что такое теги <head>, <header>, <main> и <footer> в HTML5? 

Вопрос 2: Что такое псевдоклассы в CSS и для чего они используются? 

Практическое задание: Создайте блок с текстом и кнопкой. При наведении курсора на 

блок, меняется цвет фона блока и цвет текста кнопки. 

 

Билет № 7 

Вопрос 1: Как вставить изображение на веб-страницу и какие атрибуты для этого 

используются? 

Вопрос 2: Как выровнять элементы по горизонтали и вертикали с помощью CSS? 

Практическое задание: Создайте макет, состоящий из заголовка (h1), блока с текстом 

(p) и блока с изображением. Выровняйте блок с изображением по правому краю, а текст 

по левому, используя flexbox. 

 

Билет № 8 

Вопрос 1: Что такое мета-теги и для чего они используются? 

Вопрос 2: Как задать фон элемента с помощью CSS? Приведите пример. 

Практическое задание: Создайте кнопку и задайте ей: цвет фона (с градиентом), цвет 

текста, границу, закругленные углы и эффект изменения цвета при наведении. 

 

Билет № 9 

Вопрос 1: Что такое формы в HTML и для чего они используются? 

Вопрос 2: Что такое блочная модель CSS и как она работает? 

Практическое задание: Создайте форму обратной связи с полями для ввода имени, 

email, номера телефона (с проверкой на ввод только цифр) и текстового поля для 
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сообщения. Добавьте кнопку "Отправить". При фокусе на поле, должна меняться граница 

поля. 

 

Билет № 10 

Вопрос 1: Какие типы полей ввода вы знаете? 

Вопрос 2: Как создать границу вокруг элемента с помощью CSS? Приведите пример. 

Практическое задание: Выведите таблицу с 3 строками и 4 столбцами. Добавьте рамку 

вокруг всей таблицы, а также вокруг каждой ячейки. Фон ячеек заголовка должен быть 

серым, а текст белым. 

 

Билет № 11 

Вопрос 1: Как использовать комментарии в HTML и CSS? 

Вопрос 2: Как применить несколько классов CSS к одному элементу? 

Практическое задание: Выведите три изображения в ряд, используя flexbox. Добавьте 

подписи к каждому изображению. При наведении на изображение - увеличьте его размер 

и добавьте тень. 

 

Билет № 12 

Вопрос 1: Что такое атрибут id и чем он отличается от атрибута class? 

Вопрос 2: Что такое media queries в CSS и для чего они нужны? 

Практическое задание: Создайте навигационное меню (список ul), которое будет 

располагаться горизонтально на больших экранах и вертикально на мобильных. 

 

Билет № 13 

Вопрос 1: Что такое семантическая верстка? 

Вопрос 2: Как задать прозрачность элемента с помощью CSS? Приведите пример. 

Практическое задание: Создайте два блока, один поверх другого. Верхний блок должен 

быть полупрозрачным и иметь границу. 

 

Билет № 14 

Вопрос 1: Как использовать шрифты, отличные от стандартных в HTML? 

Вопрос 2: Что такое flexbox и как он помогает создавать макеты? 

Практическое задание: Создайте макет из блока с текстом и блока с изображением, 

которые должны быть расположены рядом друг с другом на больших экранах, и друг под 

другом на мобильных. Используйте flexbox. 

 

Билет № 15 

Вопрос 1: Какие атрибуты можно использовать для ссылок? 

Вопрос 2: Что такое CSS-переменные и как их использовать? 

Практическое задание: Создайте панель навигации (вертикальную или 

горизонтальную), использующую CSS переменные для цветов и стилей. Добавьте 

анимацию при наведении на элементы меню. 

 

Билет № 16 

Вопрос 1: Что такое viewport и для чего он нужен? 

Вопрос 2: Какие есть способы позиционирования в CSS? 

Практическое задание: Создайте страницу, где в верхнем правом углу зафиксировано 
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изображение, не прокручивающееся с основным контентом. 

 

Билет № 17 

Вопрос 1: Как использовать разные стили для разных устройств? 

Вопрос 2: Какие есть способы задания цвета в CSS? 

Практическое задание: Выведите изображение с подписью. Изображение должно быть 

адаптивным. При наведении на него текст подписи должен менять цвет. 

 

Билет № 18 

Вопрос 1: Какие есть способы выравнивания элементов в CSS? 

Вопрос 2: Как сделать картинку адаптивной? 

Практическое задание: Создайте страницу с заголовком, тремя абзацами, кнопкой и 

формой. Все элементы должны быть с отступами. Используйте flexbox для выравнивания 

элементов. 

 

Билет № 19 

Вопрос 1: В чем отличие padding от margin? 

Вопрос 2: Что такое grid в CSS? 

Практическое задание: Создайте таблицу с 3 строками и 3 столбцами, используя grid. В 

таблице выведите заголовок таблицы и данные в каждой ячейке. Добавьте анимацию при 

наведении на ячейку. 

 

Билет № 20 

Вопрос 1: Как использовать background images? 

Вопрос 2: Что такое относительные и абсолютные единицы измерения в CSS? 

Практическое задание: Создайте список, где при наведении на элемент меняется цвет 

его фона и появляется иконка справа. Используйте background images. 

 

Билет № 21 

Вопрос 1: Как выровнять текст в блоке? 

Вопрос 2: Как использовать transition в CSS? 

Практическое задание: Разместите три изображения в ряд. При наведении на 

изображение оно должно немного увеличиваться и сдвигаться вверх. 

Используйте transition. 

 

Билет № 22 

Вопрос 1: Что такое кроссбраузерность? 

Вопрос 2: Как задать font-weight в CSS? 

Практическое задание: Создайте заголовок, два абзаца, список и кнопку. Задайте им 

разные шрифты (используя @font-face), цвета и размеры. 

 

Билет № 23 

Вопрос 1: Как использовать icon-font? 

Вопрос 2: Что такое z-index в CSS? 

Практическое задание: Создайте круглый блок. При наведении на него появлялась 

иконка в центре и прозрачность должна увеличиваться. Используйте z-index для 

позиционирования иконки. 
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Билет № 24 

Вопрос 1: Как использовать svg изображения? 

Вопрос 2: Что такое Box sizing в CSS? 

Практическое задание: Создайте страницу с формой (разными полями) и таблицей (с 

рамками и фоном для шапки). Разместите форму и таблицу рядом. 

 

Билет № 25 

Вопрос 1: Что такое препроцессоры CSS? 

Вопрос 2: Как работают float и clear в CSS? 

Практическое задание: Разместите блок слева, а текст справа от него, с обтеканием 

текста вокруг блока. Используйте float и clear. 

 

 

 

Экзаменационные билеты по дисциплине  « МДК 04.03 Разработка клиентской 

части информационных ресурсов» 

 

Инструкция: Каждый билет содержит два теоретических вопроса и одно практическое 

задание. Ответьте на вопросы и выполните практическое задание. 

 

Билет № 1 

Вопрос 1: Что такое DOM (Document Object Model) и как JavaScript взаимодействует с 

ним? 

Вопрос 2: Объясните разницу между var, let и const в JavaScript. 

Практическое задание: Создайте HTML-страницу с кнопкой и текстом. При нажатии на 

кнопку текст должен меняться. Используйте JavaScript для управления DOM. 

 

Билет № 2 

Вопрос 1: Что такое функции высшего порядка в JavaScript? Приведите пример. 

Вопрос 2: Что такое JSX и почему он используется в React? 

Практическое задание: Создайте простой React-компонент, который выводит заголовок 

и абзац с текстом. 

 

Билет № 3 

Вопрос 1: Что такое замыкания (closures) в JavaScript? 

Вопрос 2: Что такое props в React и как они используются для передачи данных? 

Практическое задание: Создайте React-компонент Button и передайте ему 

пропсы text (текст кнопки) и onClick (функцию-обработчик). 

 

Билет № 4 

Вопрос 1: Что такое асинхронность в JavaScript и как работают async/await? 

Вопрос 2: Что такое state в React и чем он отличается от props? 

Практическое задание: Создайте React-компонент Counter с кнопками "+" и "-". 

Используйте useState для управления состоянием счетчика. 

 

Билет № 5 
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Вопрос 1: Объясните разницу между == и === в JavaScript. 

Вопрос 2: Что такое хуки в React и для чего они используются? 

Практическое задание: Создайте React-компонент, который отображает текущее время. 

Используйте useEffect для обновления времени каждую секунду. 

 

Билет № 6 

Вопрос 1: Что такое JSON и как он используется в веб-разработке? 

Вопрос 2: Что такое условный рендеринг в React и как его реализовать? 

Практическое задание: Создайте React-компонент, который отображает сообщение в 

зависимости от значения boolean пропса (например, сообщение об успехе или ошибке). 

 

Билет № 7 

Вопрос 1: Что такое прототипное наследование в JavaScript? 

Вопрос 2: Что такое key при рендеринге списков в React и для чего он нужен? 

Практическое задание: Создайте React-компонент, который выводит список из 5 

элементов (с использованием map). 

 

Билет № 8 

Вопрос 1: Как работают обработчики событий в JavaScript? 

Вопрос 2: Какие существуют способы загрузки данных с сервера в React? 

Практическое задание: Создайте React-компонент, который загружает данные о 

пользователе с помощью fetch (используйте любой публичный API). 

 

Билет № 9 

Вопрос 1: Что такое localStorage и sessionStorage в JavaScript? 

Вопрос 2: Что такое controlled components в React и как их использовать? 

Практическое задание: Создайте форму с текстовым полем и кнопкой отправки. 

Используйте useState для управления состоянием поля. 

 

Билет № 10 

Вопрос 1: Что такое API (Application Programming Interface) и как его использовать в веб-

разработке? 

Вопрос 2: Что такое React Router и для чего он используется? 

Практическое задание: Настройте React Router для создания двух страниц: домашней и 

страницы контактов. 

 

Билет № 11 

Вопрос 1: Какие методы массивов вы знаете? 

Вопрос 2: Какие существуют способы стилизации компонентов в React? 

Практическое задание: Создайте список из 5 элементов, используя метод map. 

Стилизуйте его. 

 

Билет № 12 

Вопрос 1: Что такое debounce и throttle? 

Вопрос 2: В чем разница между state и props? 

Практическое задание: Создайте input, который будет выводить значение в консоль. 

Используйте debounce. 
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Билет № 13 

Вопрос 1: Какие есть способы создать компонент в React? 

Вопрос 2: Что такое Context API и для чего он нужен? 

Практическое задание: Создайте компонент, который выводит значение из контекста. 

 

Билет № 14 

Вопрос 1: Что такое тестирование? 

Вопрос 2: Что такое ref в React и как его использовать? 

Практическое задание: Создайте поле ввода и получите на него ref. При нажатии 

кнопки сделать фокус на этом поле. 

 

Билет № 15 

Вопрос 1: Что такое асинхронные функции и как они работают? 

Вопрос 2: Какие методы жизненного цикла есть у классовых компонентов в React? 

Практическое задание: Создайте компонент и выведите в консоль какой метод сработал 

при монтировании и при обновлении. 

 

Билет № 16 

Вопрос 1: Что такое Event bubbling и Event capturing? 

Вопрос 2: Что такое render props? 

Практическое задание: Создайте компонент, который отображает контент в 

зависимости от переданного render prop. 

 

Билет № 17 

Вопрос 1: Что такое Virtual DOM в React? 

Вопрос 2: Как работает shouldComponentUpdate? 

Практическое задание: Создайте компонент, который не будет перерендериваться при 

обновлении пропсов. 

 

Билет № 18 

Вопрос 1: Что такое higher-order components? 

Вопрос 2: В чем разница между useLayoutEffect и useEffect? 

Практическое задание: Создайте hoc который будет проверять авторизацию. 

 

Билет № 19 

Вопрос 1: Что такое memoization? 

Вопрос 2: Какие есть способы оптимизации производительности React-приложений? 

Практическое задание: Создайте компонент, использующий React.memo для избежания 

ненужных ререндеров. 

 

Билет № 20 

Вопрос 1: Что такое SSR? 

Вопрос 2: В чем разница между useCallback и useMemo? 

Практическое задание: Создайте компонент и оптимизируйте коллбеки 

через useCallback. 
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Билет № 21 

Вопрос 1: Что такое immutability? 

Вопрос 2: Для чего нужны ключи при использовании map? 

Практическое задание: Создайте список, в котором будет добавлена анимация при 

добавлении элемента. 

 

Билет № 22 

Вопрос 1: Что такое CORS и как его обойти? 

Вопрос 2: Как настроить роутинг в React? 

Практическое задание: Настройте приложение с тремя страницами, 

используйте NavLink. 

 

Билет № 23 

Вопрос 1: Что такое Redux или Context API? 

Вопрос 2: Что такое styled-components? 

Практическое задание: Создайте приложение и используйте styled-components. 

 

Билет № 24 

Вопрос 1: Что такое unit test? 

Вопрос 2: Что такое controlled components? 

Практическое задание: Создайте поле ввода, которое будет возвращать результат в 

зависимости от валидации. 

 

Билет № 25 

Вопрос 1: Что такое rest api? 

Вопрос 2: Какие есть способы обработки ошибок? 

Практическое задание: Создайте компонент, который получает данные с сервера и 

обрабатывает ошибку. 
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1. Паспорт программы 

1.1. Наименование специальности/профессии:  

« ». 

Квалификация (и):  ; 

Срок получения образования по образовательной программе -  . 

1.2. Форма ГИА   

1.3. Уровень демонстрационного экзамена   

1.4. Программа ГИА разработана на основе: 

 Федерального государственного образовательного стандарта среднего 
профессионального образования  ; 

 Порядка проведения государственной итоговой аттестации по образовательным 

программам среднего профессионального образования, утв. Приказом 

Министерства просвещения РФ №800 от 8.11.2021г; 

 Оценочных материалов для демонстрационного экзамена в 20   году; 

1.3. Цель государственной итоговой аттестации. 

Государственная итоговая аттестация проводится с целью определения 

соответствия результатов освоения студентами образовательной программы требованиям 

федерального государственного образовательного стандарта среднего профессионального 

образования по специальности/профессии   

« ». 

Задачи: (выбрать) 

демонстрационного экзамена – определение уровня освоения выпускниками 

материала, предусмотренного образовательной программой, и степени сформированности 

профессиональных умений и навыков путем проведения независимой экспертной оценки 

выполнения выпускником практических заданий в условиях реальных или 

смоделированных производственных процессов. 

Дипломного проекта (работы) – систематизация и закрепление знаний выпускника 

по специальности, а также определения уровня готовности выпускника к самостоятельной 

деятельности. 

1.4. Требования к результатам освоения основной профессиональной образовательной 

программы 

Выпускник, получивший квалификации:   

 

должен быть подготовлен к выполнению следующих основных видов деятельности: 

1. ВД 01.   

2.  

3. ВД 0….   
 

Требования ФГОС по 

профессии в 

соответствии с 

квалификациями 

Формы проверки освоения результатов 

Промежуточная аттестация ГИА 

Дифференциро

в анный зачет 

по учебным 
практикам 

Дифференциро

в анный зачет 

по 

производственн 

Экзамен 

по 

модулю 

(квалификацио
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ом практикам н ный) 
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ПК 1.1.     

ПК 1.2.     

ПК 1.3.     

ПК 1.4.     

….     

 

2. Требования к дипломным проектам (работам) 

 

3. Методика оценивания дипломного проекта (работы) 

 

 

4. Задание на демонстрационный экзамен 

описать 

Приложение 1 комплект оценочной документации с критериями оценки 

 

5. Условия проведения 

5.1. План проведения ДЭ: 

 дата и время начала проведения ДЭ, 

 расписание экзаменов в составе экзаменационных групп 

 планируемая продолжительность времени 

 технические перерывы 
 

 


